summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-10-29 18:48:28 +0200
committerDavid Craven <david@craven.ch>2016-10-29 23:51:43 +0200
commit84164f7ff88f4469145557bcde93fe97796517f5 (patch)
tree3f25c2ba9646296a944a50625178ecda164f29b6 /gnu/packages/kde-frameworks.scm
parent0e6c3057480d8fa728798b3fb783a3cff2467a48 (diff)
gnu: kpty: Update to 5.27.0.
* gnu/packages/kde-frameworks.scm (kpty): Update to 5.27.0 and fix indentation.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm30
1 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 97ac8569f6..d25f7e8e95 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1458,16 +1458,16 @@ were traditional plugins.")
(define-public kpty
(package
(name "kpty")
- (version "5.24.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/frameworks/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "1ybvdzqpa53kkki9p5da0ff9x3c63rmksk7865wqwlgy8apzi2fs"))))
+ (version "5.27.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "06pka8cbw6a9rk2j5pkz34rfy10bv6il3wqyf7ala32ynv5rcgc3"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)))
@@ -1480,11 +1480,11 @@ were traditional plugins.")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-tests
- (lambda _
- (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
- (substitute* "autotests/kptyprocesstest.cpp"
- (("/bin/bash") (which "bash")))
- #t)))))
+ (lambda _
+ (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
+ (substitute* "autotests/kptyprocesstest.cpp"
+ (("/bin/bash") (which "bash")))
+ #t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Interfacing with pseudo terminal devices")
(description "This library provides primitives to interface with pseudo