summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-09-27 21:30:01 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:05 +0100
commitfa2969388c7ebcb82ee7bf5034195041dbebcc6c (patch)
tree5023c1d3ead783e4c843d8bf460a035a702e1680 /gnu/packages/kde-frameworks.scm
parent3340dcca5afc1614b57c01ad316bd18b291e247f (diff)
gnu: krunner: Enable all tests.
* gnu/packages/kde-frameworks.scm (krunner): Use gexp. [inputs]: Add kactivities. [arguments]: Enable all tests. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm41
1 files changed, 20 insertions, 21 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 4823c732bb..4956dad6a8 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2940,7 +2940,8 @@ to easily extend the contacts collection.")
;; For tests.
dbus))
(inputs
- (list kauth
+ (list kactivities
+ kauth
kbookmarks
kcodecs
kcompletion
@@ -2961,26 +2962,24 @@ to easily extend the contacts collection.")
solid
threadweaver))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-paths-for-test
- ;; This test tries to access paths like /home, /usr/bin and /bin/ls
- ;; which don't exist in the build-container. Change to existing paths.
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "autotests/runnercontexttest.cpp"
- (("/home\"") "/tmp\"") ;; single path-part
- (("//usr/bin\"") (string-append (getcwd) "\"")) ;; multiple path-parts
- (("/bin/ls")
- (search-input-file inputs "/bin/ls")))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (setenv "HOME" (getcwd))
- (setenv "QT_QPA_PLATFORM" "offscreen")
- (invoke "dbus-launch" "ctest"
- "-E" ;; Some tests fail
- "(runnercontexttest|dbusrunnertest|\
-runnermanagersinglerunnermodetest|runnermanagertest)")))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths-for-test
+ ;; This test tries to access paths like /home, /usr/bin and /bin/ls
+ ;; which don't exist in the build-container. Change to existing paths.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "autotests/runnercontexttest.cpp"
+ (("/home\"") "/tmp\"") ;; single path-part
+ (("//usr/bin\"") (string-append (getcwd) "\"")) ;; multiple path-parts
+ (("/bin/ls")
+ (search-input-file inputs "/bin/ls")))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (setenv "HOME" (getcwd))
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ (invoke "dbus-launch" "ctest")))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Framework for Plasma runners")
(description "The Plasma workspace provides an application called KRunner