summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-games.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-08-12 17:46:31 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-12 17:46:31 +0800
commit55e7f320fd7ce8f499bfa7c6dd010669f2eaee0e (patch)
treea40f7cd783ff92011bcc9b247c94782f78f48269 /gnu/packages/kde-games.scm
parent080b8279be2fea11a21ac0400cb865268dd29620 (diff)
gnu: Add kde-games.
* gnu/packages/kde-games.scm (kde-games): New variable.
Diffstat (limited to 'gnu/packages/kde-games.scm')
-rw-r--r--gnu/packages/kde-games.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/kde-games.scm b/gnu/packages/kde-games.scm
index 8ed530d83e..dc3e81170c 100644
--- a/gnu/packages/kde-games.scm
+++ b/gnu/packages/kde-games.scm
@@ -27,6 +27,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system qt)
+ #:use-module (guix build-system trivial)
#:use-module (guix gexp)
#:use-module (gnu packages bash)
#:use-module (gnu packages compression)
@@ -1586,3 +1587,56 @@ control of the board by capturing or adding to one square.
This package is part of the KDE games module.")
(license (list license:gpl2+ license:fdl1.2+))))
+
+(define-public kde-games
+ (package
+ (name "kde-games")
+ (version "23.04.3")
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments
+ (list #:builder #~(mkdir #$output)))
+ (propagated-inputs
+ ;; TODO: kpat, klickety, katomic, knights.
+ (list bomber
+ bovo
+ granatier
+ kajongg
+ kapman
+ kblackbox
+ kblocks
+ kbounce
+ kbreakout
+ kdiamond
+ kfourinline
+ kgoldrunner
+ kigo
+ killbots
+ kiriki
+ kjumpingcube
+ klines
+ kmahjongg
+ kmines
+ knavalbattle
+ knetwalk
+ kolf
+ kollision
+ konquest
+ kreversi
+ kshisen
+ ksirk
+ ksnakeduel
+ kspaceduel
+ ksquares
+ ksudoku
+ ktuberling
+ kubrick
+ lskat
+ palapeli
+ picmi))
+ (home-page "https://apps.kde.org/categories/games/")
+ (synopsis "KDE Games")
+ (description "This metapackage includes a collection of games provided
+with the official release of KDE.")
+ (license
+ (list license:gpl2+ license:lgpl2.0+ license:gpl3+ license:fdl1.2+))))