summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-pim.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2021-10-14 18:25:20 +1100
committerMarius Bakke <marius@gnu.org>2022-09-01 16:08:15 +0200
commit0d3d6fd71b94268ca7a5add1f39205be73586e15 (patch)
treeed3a4e8d3fae59b94e92e5fa2fd20083654a73f3 /gnu/packages/kde-pim.scm
parent7fc78b2d34e8914fa98114dd11ae85a47e7e6e89 (diff)
gnu: libgravatar: Move to (gnu packages kde-pim).
Remove uneeded (gnu packages kde-internet) import. * gnu/packages/kde-internet.scm: Move libgravatar ... * gnu/packages/kde-pim.scm ...here Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/kde-pim.scm')
-rw-r--r--gnu/packages/kde-pim.scm34
1 files changed, 33 insertions, 1 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index d895a74fd2..9d7a0bf202 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2017, 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2022 Brendan Tildesley <mail@brendan.scot>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,7 +35,6 @@
#:use-module (gnu packages gnupg)
#:use-module (gnu packages kde)
#:use-module (gnu packages kde-frameworks)
- #:use-module (gnu packages kde-internet)
#:use-module (gnu packages openldap)
#:use-module (gnu packages qt)
#:use-module (gnu packages search)
@@ -1641,6 +1641,38 @@ Virtual Contact File}) files to the KPeople contact management library.")
(license ;; GPL for programs, LGPL for libraries
(list license:gpl2+ license:lgpl2.0+))))
+(define-public libgravatar
+ (package
+ (name "libgravatar")
+ (version "20.04.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/libgravatar-" version ".tar.xz"))
+ (sha256
+ (base32 "0981ci2kr20v4fk11h57rqya0brgslfazpgq1yk5yqiwyqqm49r2"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("kconfig" ,kconfig)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("kpimcommon" ,kpimcommon)
+ ("ktextwidgets" ,ktextwidgets)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("qtbase" ,qtbase-5)))
+ (arguments
+ `(#:tests? #f)) ;; 2/7 tests fail (due to network issues?)
+ (home-page "https://invent.kde.org/pim/libgravatar")
+ (synopsis "Online avatar lookup library")
+ (description "This library retrieves avatar images based on a
+hash from a person's email address, as well as local caching to avoid
+unnecessary network operations.")
+ (license ;; GPL for programs, LGPL for libraries
+ (list license:gpl2+ license:lgpl2.0+))))
+
(define-public kpimtextedit
(package
(name "kpimtextedit")