summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-pim.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-10-03 17:09:31 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:16 +0100
commitbeb859d52b0e0ab904bb0344d5d36b50be4eb4b7 (patch)
tree916d8a223870d23c41d73e134496bf9a42135da1 /gnu/packages/kde-pim.scm
parentcc1ff122d71e32095cf81e5f2e8e01b3d0d0fc24 (diff)
gnu: Add khealthcertificate.
* gnu/packages/kde-pim.scm (khealthcertificate): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/kde-pim.scm')
-rw-r--r--gnu/packages/kde-pim.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 5952beeffa..f98204cc63 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -895,6 +895,40 @@ for applying cryptography to short pieces of text, and can also quickly apply
cryptography to the contents of the clipboard.")
(license license:gpl2+)))
+(define-public khealthcertificate
+ (package
+ (name "khealthcertificate")
+ (version "22.09")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma-mobile/"
+ (version-major+minor version)
+ "/khealthcertificate-" version ".tar.xz"))
+ (sha256
+ (base32
+ "16vkjpyxwx34pvdpnci0l6mx2bdjialiscjvbdx53xbsq9ff701k"))))
+ (build-system qt-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "ctest" "-E"
+ "(icaovdsparsertest|nlcoronacheckparsertest)")))))))
+ (native-inputs (list extra-cmake-modules pkg-config))
+ (inputs (list karchive
+ kcodecs
+ ki18n
+ openssl
+ qtdeclarative-5
+ zlib))
+ (home-page "https://api.kde.org/khealthcertificate/html/index.html")
+ (synopsis "Digital vaccination and recovery certificate library")
+ (description
+ "This package provides a library for arsing of digital vaccination,
+test and recovery certificates.")
+ (license license:lgpl2.0)))
+
(define-public kidentitymanagement
(package
(name "kidentitymanagement")