summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-03-25 11:36:00 +0100
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:13 +0100
commit28ce8094e231629ae53c2bedbf133656f415186c (patch)
tree42ca3f2a5f0d310e5a6ea1abebc8c0b134c7a8fc /gnu/packages/kde-plasma.scm
parent6fb72a8f0dbfb6f67ee9e7b8399f4a3a06f6a266 (diff)
gnu: Add plasma-mobile.
* gnu/packages/kde-plasma.scm (plasma-mobile): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 1bb961cf76..f0cef617a5 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1789,6 +1789,46 @@ integration of Qt applications when running on a KDE Plasma workspace.")
connections.")
(license (list license:lgpl2.1 license:lgpl3))))
+(define-public plasma-mobile
+ (package
+ (name "plasma-mobile")
+ (version "5.24.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://download.kde.org/stable/plasma/"
+ version "/plasma-mobile-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1bwmy7xvd8wmh0snqqjh9jjgawib8ks2g30w48sqxwhplhf3da58"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-script
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program (string-append #$output
+ "/bin/kwinwrapper")
+ `("PATH" ":" prefix
+ (,(string-append #$plasma-framework
+ "/bin")))))))))
+ (native-inputs (list extra-cmake-modules pkg-config qttools))
+ (inputs (list bash-minimal
+ kdeclarative
+ ki18n
+ kio
+ knotifications
+ kwayland
+ kwin
+ modemmanager-qt
+ networkmanager-qt
+ plasma-framework
+ qtbase-5))
+ (home-page "https://plasma-mobile.org/")
+ (synopsis
+ "General UI components for Plasma Phone including shell, containment and applets")
+ (description "This package provides user-friendly, privacy-enabling and
+customizable platform for mobile devices.")
+ (license (list license:gpl3+ license:lgpl2.1+))))
+
(define-public plasma-pa
(package
(name "plasma-pa")