summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-08-26 06:12:31 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:11 +0100
commitc939f558552f7284be30ac461dca2497541363ca (patch)
tree80e15220b25902f569b54b966b9e2416ac36e577 /gnu/packages/kde-plasma.scm
parentebd651c32a8bf2f37e95f2ea63f9de715f3d0e83 (diff)
gnu: Add discover.
* gnu/packages/kde-plasma.scm (discover): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm86
1 files changed, 86 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 20d2b27755..e67ee58970 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -37,6 +37,10 @@
#:use-module (gnu packages authentication)
#:use-module (gnu packages bash)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages elf) ; patchelf
+ #:use-module (gnu packages display-managers)
+ #:use-module (gnu packages firmware)
+ #:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -48,6 +52,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
+ #:use-module (gnu packages package-management) ; flatpak
#:use-module (gnu packages video)
#:use-module (gnu packages vpn)
#:use-module (gnu packages qt)
@@ -126,6 +131,87 @@ Breeze is the default theme for the KDE Plasma desktop.")
(license (list license:bsd-3 ;cmake/FindSass.cmake
license:lgpl2.1+)))) ;<all other files>
+(define-public discover
+ (package
+ (name "discover")
+ (version "5.25.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/"
+ version
+ "/"
+ name
+ "-"
+ version
+ ".tar.xz"))
+ (sha256
+ (base32
+ "01vdi66c7v60db25p0qi0q73wgqw6dy2kirbk34bvhld41gpxhhv"))))
+ (build-system qt-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'fix-so
+ (lambda* _
+ (invoke "patchelf" "--replace-needed"
+ "libDiscoverCommon.so"
+ (string-append #$output
+ "/lib/plasma-discover/libDiscoverCommon.so")
+ (string-append #$output
+ "/lib/qt5/plugins/discover/fwupd-backend.so"))
+ (invoke "patchelf" "--replace-needed"
+ "libDiscoverCommon.so"
+ (string-append #$output
+ "/lib/plasma-discover/libDiscoverCommon.so")
+ (string-append #$output
+ "/lib/qt5/plugins/discover/packagekit-backend.so"))
+ (invoke "patchelf" "--replace-needed"
+ "libDiscoverCommon.so"
+ (string-append #$output
+ "/lib/plasma-discover/libDiscoverCommon.so")
+ (string-append #$output
+ "/lib/qt5/plugins/discover/kns-backend.so"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "ctest" "-E" "knsbackendtest")))))))
+ (native-inputs (list extra-cmake-modules patchelf pkg-config))
+ (inputs (list appstream-qt
+ attica
+ fwupd ; optional
+ flatpak ; optional
+ kcoreaddons
+ kconfig
+ kcrash
+ kdbusaddons
+ ki18n
+ karchive
+ kxmlgui
+ kirigami
+ kuserfeedback
+ knewstuff
+ knotifications
+ kio
+ kdeclarative
+ kcmutils
+ kidletime
+ packagekit-qt5
+ qtdeclarative-5
+ qtgraphicaleffects
+ qtquickcontrols2-5))
+ ;; -- The following features have been disabled:
+ ;; * Ostree, Library to manage ostree repository. Required to build the rpm-ostree backend
+ ;; * RpmOstree, rpm-ostree binary to manage the system. Required to build the rpm-ostree backend
+ ;;
+ ;; -- The following OPTIONAL packages have not been found:
+ ;; * Snapd, Library that exposes Snapd, <https://www.snapcraft.io>
+ ;; Required to build the Snap backend
+ (synopsis "KDE and Plasma resources management GUI")
+ (description
+ "This package provides a way to find and install applications,
+games, and tools.")
+ (home-page "https://invent.kde.org/plasma/discover")
+ (license (list license:gpl2 license:gpl3))))
+
(define-public drkonqi
(package
(name "drkonqi")