summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2023-07-20 10:20:27 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-02 22:27:43 +0800
commitf53e4524b51f479fe307e74fbde2002633c99259 (patch)
tree5de9955bfa3f00ecc5917f737dcc0911d23c82e2 /gnu/packages/kde-plasma.scm
parenta5e90e67a6c1f0ae2f1eb638bc1b9f69237a8e68 (diff)
gnu: plasma-desktop: Update to 5.27.6.
* gnu/packages/kde-plasma.scm (plasma-desktop): Update to 5.27.6. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm19
1 files changed, 5 insertions, 14 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index af5cc5a67d..46ac85acf4 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1605,14 +1605,14 @@ the KDE Plasma 5 desktop.")
(define-public plasma-desktop
(package
(name "plasma-desktop")
- (version "5.25.5")
+ (version "5.27.6")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/plasma/" version
"/" name "-" version ".tar.xz"))
(sha256
(base32
- "05s1pkwr4xmkghp8jrwcyrvjm83n68ngmk2694055xcfgi0pxicg"))))
+ "10x68lqg6zxb8fajd277lm0qfrdg2jz7m58l3wna4nv9bni5wj72"))))
(build-system qt-build-system)
(native-inputs (list extra-cmake-modules
dbus
@@ -1620,7 +1620,9 @@ the KDE Plasma 5 desktop.")
intltool
pkg-config
qtsvg-5
- qttools-5))
+ qttools-5
+ ;; require QtWaylandScanner
+ qtwayland-5))
(inputs (list packagekit-qt5
signon-plugin-oauth2
signond
@@ -1724,17 +1726,6 @@ the KDE Plasma 5 desktop.")
(string-append "\"" (search-input-directory
inputs "/share/xml/iso-codes")
"\"")))))
- (add-after 'unpack 'patch-qml-import-path
- (lambda _
- (substitute*
- '("applets/pager/package/contents/ui/main.qml"
- "containments/desktop/package/contents/ui/FolderView.qml"
- "containments/desktop/package/contents/ui/main.qml"
- "containments/panel/contents/ui/main.qml")
- (("^import \"(utils|FolderTools|LayoutManager).js\" as "
- line mod)
- (string-append "import \"../code/" mod
- ".js\" as ")))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?