summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-08-10 01:20:21 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:10 +0100
commit3cdecf5f5e313f521e7770ca6a697baec0772eb4 (patch)
tree0ba96b7010c55caedf7641a2fe8b44cb09639f91 /gnu/packages/kde-plasma.scm
parent4b39a8a55ffddfd069055d6a9c78ea7edbff9d44 (diff)
gnu: Add latte-dock.
* gnu/packages/kde-plasma.scm (latte-dock): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 480f946aa8..d0a12f88ac 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -290,6 +290,48 @@ directly, you need to tell @code{ssh-add} about it. @code{ssh-add} will then
call it if it is not associated to a terminal.")
(license license:gpl2+)))
+(define-public latte-dock
+ (package
+ (name "latte-dock")
+ (version "0.10.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/latte-dock/"
+ "latte-dock-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0ali9i0y0y1c5mdaps5ybhk4nqvzzs5jq27wj8rg8xxqjyfvbah0"))))
+ (build-system cmake-build-system)
+ (native-inputs (list extra-cmake-modules))
+ (inputs (list qtbase-5
+ qtdeclarative-5
+ knotifications
+ kwindowsystem
+ kio
+ plasma-framework
+ kwayland
+ kactivities
+ kcrash
+ kiconthemes
+ knewstuff
+ karchive
+ kguiaddons
+ kdbusaddons
+ kglobalaccel
+ kirigami
+ ki18n
+ kdeclarative
+ kcoreaddons
+ xcb-util
+ qtx11extras
+ libsm))
+ (synopsis "Latte is a dock based on plasma frameworks")
+ (description
+ "Latte is a dock based on plasma frameworks that provides
+an elegant and intuitive experience for your tasks and plasmoids.")
+ (home-page "https://github.com/KDE/latte-dock")
+ (license license:gpl2+)))
+
(define-public layer-shell-qt
(package
(name "layer-shell-qt")