summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-08-26 07:23:20 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:11 +0100
commit9366402ef2dafd0aed865c86091d11a65d9b0c35 (patch)
treef2f1bc594769b85ba2e8a02e6a59d118b9ef38cf /gnu/packages/kde-plasma.scm
parent787fd473bef78d955cb735b1aa565b471bb4bb37 (diff)
gnu: Add ksystemstats.
* gnu/packages/kde-plasma.scm (ksystemstats): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 6a87a67331..860c54c98b 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -409,6 +409,46 @@ directly, you need to tell @code{ssh-add} about it. @code{ssh-add} will then
call it if it is not associated to a terminal.")
(license license:gpl2+)))
+(define-public ksystemstats
+ (package
+ (name "ksystemstats")
+ (version "5.25.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/"
+ version "/" name "-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "07xm6gn2k3vsl1pkrd2n9w8w8b7jq26h3cpslqha4ipw0by2mlqa"))))
+ (build-system qt-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "ctest" "-E" "ksystemstatstest")))))))
+ (native-inputs (list extra-cmake-modules pkg-config))
+ (inputs (list glib
+ kcoreaddons
+ kdbusaddons
+ solid
+ networkmanager-qt
+ kiconthemes
+ kio
+ ki18n
+ libksysguard
+ libnl
+ eudev
+ `(,lm-sensors "lib")
+ network-manager))
+ (synopsis "Plugin based system monitoring daemon")
+ (description
+ "This package provides a daemon that collects statistics about
+the running system.")
+ (home-page "https://invent.kde.org/plasma/ksystemstats")
+ (license (list license:gpl2 license:gpl3))))
+
(define-public latte-dock
(package
(name "latte-dock")