summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-systemtools.scm
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2023-07-15 13:43:18 +0800
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-17 15:09:44 -0400
commit9db27cda0904ca16e2a8cb84ec689285725562af (patch)
treeed4ebbd9b57b4cb0c1ecbb9f0bdb4e60151c42cd /gnu/packages/kde-systemtools.scm
parent6b84bb72e87d74ae6e4868b41b3430226dc579d8 (diff)
gnu: khelpcenter: Use G-expressions.
* gnu/packages/kde-systemtools.scm (khelpcenter)[arguments]: Rewrite as G-expressions. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/kde-systemtools.scm')
-rw-r--r--gnu/packages/kde-systemtools.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/kde-systemtools.scm b/gnu/packages/kde-systemtools.scm
index 52a711a1bb..3a2d0e6cd3 100644
--- a/gnu/packages/kde-systemtools.scm
+++ b/gnu/packages/kde-systemtools.scm
@@ -26,6 +26,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
+ #:use-module (guix gexp)
#:use-module (gnu packages)
#:use-module (gnu packages compression)
#:use-module (gnu packages freedesktop)
@@ -164,17 +165,17 @@ Dolphin with the version control systems: Bzr, Git, Mercurial, Subversion.")
qtbase-5
xapian))
(arguments
- `(#:tests? #f ;; 1/1 test fails
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'wrap-executable
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out")))
- ;; Since qt-wrap selectors do not wrap for /share/kf5
- ;; directories, we need this so khelpcenter can find html4.css.
- (wrap-program (string-append out "/bin/khelpcenter")
- `("XDG_DATA_DIRS" suffix
- (,(string-append (assoc-ref inputs "khtml") "/share"))))))))))
+ (list #:tests? #f ;;1/1 test fails
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Since qt-wrap selectors do not wrap for /share/kf5
+ ;; directories, we need this so khelpcenter can find html4.css.
+ (wrap-program (string-append #$output
+ "/bin/khelpcenter")
+ `("XDG_DATA_DIRS" suffix
+ (,(string-append (assoc-ref inputs "khtml")
+ "/share")))))))))
(home-page "https://apps.kde.org/khelpcenter/")
(synopsis "KDE documentation viewer")
(description "KHelpCenter uses meta data files which describe the