summaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-09-24 21:13:13 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:07 +0100
commite8ddc727d89177fae4d5a9eb40395853ecce53b3 (patch)
treed78f558f6357c1adc91f6074ea3c22ca73de8895 /gnu/packages/kde.scm
parent060251a00e5a20a025a1dfdb6fb93d105a1ae009 (diff)
gnu: KDE: Update to 22.08.1.
* gnu/packages/kde.scm (baloo-widgets, grantleetheme, akregator, kdenlive, kdevelop, libkomparediff2, kpmcore, kdeconnect, labplot, kdf, kcachegrind, libkdegames, marble-qt, okular, poxml, kdegraphics-mobipocket, libkexiv2): Update to 22.08.1. (kdeconnect)[inputs]: Add plasma-wayland-protocols. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm61
1 files changed, 31 insertions, 30 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index ff50cb6c9f..61ffd1830b 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -99,14 +99,14 @@
(define-public baloo-widgets
(package
(name "baloo-widgets")
- (version "22.04.3")
+ (version "22.08.1")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/release-service/" version
"/src/baloo-widgets-" version ".tar.xz"))
(sha256
- (base32 "0084bnrlbdypdwzxi9gfxcywhyjd1z2cmh7p6gv0zhc9f7h6ffnp"))))
+ (base32 "02p4v8g4syk908mg7f0l5fpqn7ddsxqji1n8jqghsdkkdsvry7mn"))))
(build-system qt-build-system)
(native-inputs
(list extra-cmake-modules))
@@ -151,14 +151,14 @@ This package contains GUI widgets for baloo.")
(define-public akregator
(package
(name "akregator")
- (version "22.04.3")
+ (version "22.08.1")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/release-service/" version
"/src/akregator-" version ".tar.xz"))
(sha256
- (base32 "08n713271i7ifnbrgwrqmxvcpvj45wfqjiidw8zf9rpwxg2m2m9g"))))
+ (base32 "01rgyl2hwjprq4z5yjc99j6jk9vrhjy608ha72j470pw6g47ac5s"))))
(build-system qt-build-system)
(arguments
`(#:phases
@@ -220,7 +220,7 @@ browser for easy news reading.")
(define-public kdenlive
(package
(name "kdenlive")
- (version "22.04.3")
+ (version "22.08.1")
(source
(origin
(method git-fetch)
@@ -229,7 +229,7 @@ browser for easy news reading.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0v545kd5rm5isy4cx21fp3pi49mvsv1r1ahp0jhim8s6b7ghrh64"))))
+ (base32 "0xnasi8s8zxh2s4vnn51pc8ni58q8pk70bwh9dfxp1wdmpv3zsrx"))))
(build-system qt-build-system)
(arguments
;; XXX: there is a single test that spawns other tests and
@@ -304,14 +304,14 @@ projects.")
(define-public kdevelop
(package
(name "kdevelop")
- (version "22.04.3")
+ (version "22.08.1")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/release-service/" version
"/src/kdevelop-" version ".tar.xz"))
(sha256
- (base32 "03dwllxy96sy20kdsc3sll0n6bhh6gdmpjl821flsxv0jb5naplv"))))
+ (base32 "14a80z4sahxyzssrz605zp7ah5xdjbc22ccv0vwcnhr5lzr76v31"))))
(build-system qt-build-system)
(native-inputs
(list extra-cmake-modules pkg-config shared-mime-info qttools-5))
@@ -584,14 +584,14 @@ compressed massif files can also be opened transparently.")
(define-public libkomparediff2
(package
(name "libkomparediff2")
- (version "22.04.3")
+ (version "22.08.1")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/release-service/" version
"/src/libkomparediff2-" version ".tar.xz"))
(sha256
- (base32 "1vaxbx7c6r7skh3452blxyrngfcsdyjmmvcg6j2wcsn04m01mw8k"))))
+ (base32 "0hjxxhfv0ds05l821avq787sfdy0afr595xx266c20x8fxgm6kv9"))))
(native-inputs
(list extra-cmake-modules pkg-config))
(inputs
@@ -639,7 +639,7 @@ cards.")
(define-public kpmcore
(package
(name "kpmcore")
- (version "22.04.3")
+ (version "22.08.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -647,7 +647,7 @@ cards.")
"/src/" name "-" version ".tar.xz"))
(sha256
(base32
- "04qslli4vnbnl329zynbinlwaigxr9xpswra5n0v710p92as0qif"))))
+ "1y28dnmbnkkjar4kl033fkmcnazgczc3pgdac2q1ry2hjzkcbnpa"))))
(build-system cmake-build-system)
(native-inputs
(list extra-cmake-modules pkg-config))
@@ -703,7 +703,7 @@ different notification systems.")
(define-public kdeconnect
(package
(name "kdeconnect")
- (version "22.04.3")
+ (version "22.08.1")
(source
(origin
(method url-fetch)
@@ -712,7 +712,7 @@ different notification systems.")
version ".tar.xz"))
(sha256
(base32
- "015gxglclds2vmjr4bv51yfv840bafzgrl71cnwgnwwy8rrh9x4x"))))
+ "1yzx49gcm7x2wdk53iznyjz09y2a6mrrhh68xilbcsafyiw3l3zr"))))
(build-system qt-build-system)
(arguments
`(#:configure-flags '("-DBUILD_TESTING=ON"
@@ -741,6 +741,7 @@ different notification systems.")
kpeoplevcard
kwayland
libfakekey
+ plasma-wayland-protocols
pulseaudio-qt
qca
qqc2-desktop-style
@@ -850,14 +851,14 @@ to perform data analysis.")
(define-public kdf
(package
(name "kdf")
- (version "22.04.3")
+ (version "22.08.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/release-service/"
version "/src/kdf-" version ".tar.xz"))
(sha256
(base32
- "1m0dwk3inqzk9kjjzgsaam15lnpbhzjfmwrzv8sazfk44scnr2v1"))))
+ "0p7iqld2phc74pmhyb8bqqg9clnc7l2rh6hd0i6jcsp266cgg205"))))
(build-system qt-build-system)
(native-inputs
(list extra-cmake-modules kdoctools))
@@ -910,14 +911,14 @@ timers for each task can be started, stopped, changed, or looped.")
(define-public kcachegrind
(package
(name "kcachegrind")
- (version "22.04.3")
+ (version "22.08.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/release-service/" version
"/src/kcachegrind-" version ".tar.xz"))
(sha256
(base32
- "12ckn90hqm2c5c58xqkzgcih64jk4kwkgz4q0f5ns1rxv3pidz5n"))))
+ "05wcnfqs0fdfhfpagn0pqky0l7014nblv8r9fv1khy4g5mdlm4hs"))))
(build-system cmake-build-system)
(native-inputs
(list extra-cmake-modules perl python qttools-5 kdoctools))
@@ -944,14 +945,14 @@ Python, PHP, and Perl.")
(define-public libkdegames
(package
(name "libkdegames")
- (version "22.04.3")
+ (version "22.08.1")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/release-service/" version
"/src/libkdegames-" version ".tar.xz"))
(sha256
- (base32 "0igq87anam9x2mclb0lkvwhrxk62y1f4xl14a4dhd97mqsc5pbzn"))))
+ (base32 "1aihbha073fw2bxmdk4l768716kvrlyjd72x2nfx0vvr0ngc5wx9"))))
(build-system qt-build-system)
(native-inputs
(list extra-cmake-modules))
@@ -990,7 +991,7 @@ Python, PHP, and Perl.")
(define-public marble-qt
(package
(name "marble-qt")
- (version "22.04.3")
+ (version "22.08.1")
(source
(origin
(method git-fetch)
@@ -1000,7 +1001,7 @@ Python, PHP, and Perl.")
(file-name (git-file-name name version))
(sha256
(base32
- "1saacnrl0hkl32nq96l1bgn9yrsz455q96jdxzp7ax8iaa5nmdiz"))))
+ "0pn0mjh5cg7mgjj82bsj8zikzdyq2fmzckdcav2y0msxwi859crl"))))
(build-system qt-build-system)
(arguments
;; FIXME: libmarblewidget-qt5.so.28 not found. Also enable the
@@ -1047,14 +1048,14 @@ creating routes by drag and drop and more.")
(define-public okular
(package
(name "okular")
- (version "22.04.3")
+ (version "22.08.1")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/release-service/" version
"/src/" name "-" version ".tar.xz"))
(sha256
- (base32 "03jpwgrhjgyx14g1h3lxhnyib88ck0qkqcxh4fpc398xwdr3amkw"))))
+ (base32 "0f98kfsb6sirpym27j2wwz4qr4p5vl4pbnckxd3gmgyfpz8mszln"))))
(build-system qt-build-system)
;; The tests fail because they can't find the proper mimetype plugins:
;; "org.kde.okular.core: No plugin for mimetype '"image/jpeg"'."
@@ -1112,7 +1113,7 @@ a variety of formats, including PDF, PostScript, DejaVu, and EPub.")
(define-public poxml
(package
(name "poxml")
- (version "22.04.3")
+ (version "22.08.1")
(source (origin
(method url-fetch)
(uri
@@ -1120,7 +1121,7 @@ a variety of formats, including PDF, PostScript, DejaVu, and EPub.")
"/src/poxml-" version ".tar.xz"))
(sha256
(base32
- "1nrp0i3a39pw4pzcanpmjyks3pl1lyfj3zq61ii8xx402xw1ip2w"))))
+ "13jp5g5la3kq9i3qybdvwfl4vgqz3hxf64qzmh7kl71ykas7s5vi"))))
(build-system cmake-build-system)
(native-inputs
(list extra-cmake-modules kdoctools))
@@ -1137,14 +1138,14 @@ PO template files.")
(define-public kdegraphics-mobipocket
(package
(name "kdegraphics-mobipocket")
- (version "22.04.3")
+ (version "22.08.1")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/release-service/" version
"/src/" name "-" version ".tar.xz"))
(sha256
- (base32 "12yrwa22c4qxsf10fv76fzaaj5xlv5lmrwcqvf6qhgr6f9qsw7sj"))))
+ (base32 "1kxvzgmq83hml10pc4j66r59dsar7h92w2i0cs1nhar781mz666n"))))
(build-system cmake-build-system)
(native-inputs
(list extra-cmake-modules))
@@ -1159,14 +1160,14 @@ Mobipocket e-books in Dolphin and other KDE apps.")
(define-public libkexiv2
(package
(name "libkexiv2")
- (version "22.04.3")
+ (version "22.08.1")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/release-service/" version
"/src/" name "-" version ".tar.xz"))
(sha256
- (base32 "0p43z69yh5jk8m1hn3xynjpgzxpkc89h0dafj5964qx4xp4vxl19"))))
+ (base32 "0iwpy79ppv4bbsqrszp9kmghgjvkl13gdpnafsbikh4wy1ch4cv9"))))
(build-system cmake-build-system)
(native-inputs
(list extra-cmake-modules))