summaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorSughosha <sughosha@disroot.org>2023-08-12 23:05:54 +0200
committer宋文武 <iyzsong@member.fsf.org>2023-08-13 12:42:36 +0800
commit0ee45f48e7336cb7b14c4a086ef31d7043f29839 (patch)
tree99a522b62cc15460912a0863b715106239584d24 /gnu/packages/kde.scm
parentb46e936ae6fa04d1cf2c7727394b0f8c730dadd1 (diff)
gnu: Add kompare.
* gnu/packages/kde.scm (kompare): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 18d83d89f3..cce059641c 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -891,6 +891,50 @@ cards.")
"Kommit is a git client for KDE.")
(license license:gpl3+)))
+(define-public kompare
+ (package
+ (name "kompare")
+ (version "23.04.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/kompare-" version ".tar.xz"))
+ (sha256
+ (base32
+ "058rr0n5r9czxqs6ixacx0bm8hglwjmhfpf5xf1zr0fjgcirlrwy"))))
+ (build-system qt-build-system)
+ (native-inputs
+ (list extra-cmake-modules kdoctools))
+ (inputs
+ (list libkomparediff2
+ kcodecs
+ kconfig
+ kcoreaddons
+ kiconthemes
+ kjobwidgets
+ kparts
+ ktexteditor
+ kwidgetsaddons))
+ (home-page "https://apps.kde.org/kompare/")
+ (synopsis "Graphical file differences tool")
+ (description
+ "Kompare is a program to view the differences between files. Features
+include:
+@itemize
+@item comparison of files or directories via a graphical interface,
+@item bezier-based connection widget letting you see both source and destination,
+@item graphical viewing of patch files in normal, context, unified and diff
+ formats,
+@item interactive application of differences,
+@item network transparency,
+@item ability to view plain-text diff output in embedded viewer,
+@item navigation of multiple-file diffs with dockable navigation tree,
+@item graphical interface for commonly used diff command line options,
+@item switch source and destination
+@item and diff statistics.
+@end itemize")
+ (license license:gpl3+)))
+
(define-public kopeninghours
(package
(name "kopeninghours")