summaryrefslogtreecommitdiff
path: root/gnu/packages/lean.scm
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2023-11-21 12:48:29 +0800
committerLudovic Courtès <ludo@gnu.org>2023-12-11 23:39:05 +0100
commit46ec8592f7f59cde049c7870da719ff5a9d557c4 (patch)
treef0b66b5d1aa2993730f741c53b4c7e18aaddb06b /gnu/packages/lean.scm
parentf1bcc043a4d471854d6fae7355643c4667929e02 (diff)
gnu: lean: Update to 3.51.1.
* gnu/packages/lean.scm (lean): Update to 3.51.1. [home-page]: Use new home page. [arguments]<#:phases>: Remove stale phase 'patch-tests-shebangs'. [inputs]: Remove bash-minimal. Change-Id: Ib90a124b4a6b06fb30223ad4b9254249e56dd086 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/lean.scm')
-rw-r--r--gnu/packages/lean.scm24
1 files changed, 7 insertions, 17 deletions
diff --git a/gnu/packages/lean.scm b/gnu/packages/lean.scm
index a8ad085d7e..1533200426 100644
--- a/gnu/packages/lean.scm
+++ b/gnu/packages/lean.scm
@@ -40,19 +40,20 @@
(define-public lean
(package
(name "lean")
- (version "3.41.0")
- (home-page "https://github.com/leanprover-community/lean")
+ (version "3.51.1")
+ (home-page "https://lean-lang.org" )
(source (origin
(method git-fetch)
- (uri (git-reference (url home-page)
- (commit (string-append "v" version))))
+ (uri (git-reference
+ (url "https://github.com/leanprover-community/lean")
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "0mpxlfjq460x1vi3v6qzgjv74asg0qlhykd51pj347795x5b1hf1"))))
+ "17g4d3lqnbl1yfy2pjannf73v8qhc5003d2jkmrqiy05zkqs8d9n"))))
(build-system cmake-build-system)
(inputs
- (list bash-minimal gmp))
+ (list gmp))
(arguments
(list
#:build-type "Release" ; default upstream build type
@@ -65,17 +66,6 @@
(string-prefix? "armhf" arch)))))
#:phases
#~(modify-phases %standard-phases
- (add-after 'patch-source-shebangs 'patch-tests-shebangs
- (lambda _
- (let ((sh (which "sh"))
- (bash (which "bash")))
- (substitute* (find-files "tests/lean" "\\.sh$")
- (("#![[:blank:]]?/bin/sh")
- (string-append "#!" sh))
- (("#![[:blank:]]?/bin/bash")
- (string-append "#!" bash))
- (("#![[:blank:]]?usr/bin/env bash")
- (string-append "#!" bash))))))
(add-before 'configure 'chdir-to-src
(lambda _ (chdir "src"))))))
(synopsis "Theorem prover and programming language")