summaryrefslogtreecommitdiff
path: root/gnu/packages/lesstif.scm
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2023-01-28 20:24:25 -0800
committer宋文武 <iyzsong@member.fsf.org>2023-02-10 14:01:03 +0800
commit0ac85f3caa56bfdeffae295e174d1cae9bbdbfef (patch)
tree406d83cccba3d0dfc30eed08ff985d8f06d6e6cc /gnu/packages/lesstif.scm
parentf5bb96700c44c8c56934f8837e66b03b9db87730 (diff)
gnu: Add motif.
* gnu/packages/lesstif.scm (motif): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/lesstif.scm')
-rw-r--r--gnu/packages/lesstif.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/lesstif.scm b/gnu/packages/lesstif.scm
index 8f017f41be..5d902ba92f 100644
--- a/gnu/packages/lesstif.scm
+++ b/gnu/packages/lesstif.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,6 +22,12 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix git-download)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages c)
+ #:use-module (gnu packages flex)
+ #:use-module (gnu packages fontutils)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages xorg))
@@ -46,3 +53,36 @@
(synopsis "Clone of the Motif toolkit for the X window system")
(description "Clone of the Motif toolkit for the X window system.")
(license license:gpl2+))) ; some files are lgpl2.1+ or x11
+
+(define-public motif
+ ;; This commit is from September 2021 and v2.3.8 from 2017.
+ (let ((commit "59858b0811e8d9dfaeb142f2b5a96f55482be1ed")
+ (revision "0"))
+ (package
+ (name "motif")
+ (version (git-version "2.3.8" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.code.sf.net/p/motif/code")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0yycq0vzga9qmgbfzn2d02ilpwxixwdv2j1d8sddl4dripcrg21m"))))
+ (build-system gnu-build-system)
+ (inputs
+ (list libx11 xorgproto))
+ (propagated-inputs
+ (list fontconfig freetype libxext libxft libxpm libxt xbitmaps))
+ (native-inputs
+ (list autoconf automake byacc flex libtool pkg-config))
+ (home-page "https://motif.ics.com/motif")
+ (synopsis "Motif toolkit for the X window system")
+ (description "Motif is a standard graphical user interface, (as defined
+by the IEEE 1295 specification), used on more than 200 hardware and software
+platforms. It provides application developers, end users, and system vendors
+with a widely used environment for standardizing application presentation on a
+wide range of platforms.")
+ (license license:lgpl2.1+))))