summaryrefslogtreecommitdiff
path: root/gnu/packages/libapr.scm
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2013-01-25 20:42:50 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-25 21:52:08 +0100
commit695e671723f482a101daf3c1d39aa5a76c922bb9 (patch)
treeeb4ccab97ef789b0107a58e1e94620815488a88c /gnu/packages/libapr.scm
parentdf84950e44050ae98d7e77905ceda381e43a4127 (diff)
gnu: Add libaprutil.
* gnu/packages/libapr: new variable.
Diffstat (limited to 'gnu/packages/libapr.scm')
-rw-r--r--gnu/packages/libapr.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/libapr.scm b/gnu/packages/libapr.scm
index 36f0e1ec31..b342e77929 100644
--- a/gnu/packages/libapr.scm
+++ b/gnu/packages/libapr.scm
@@ -56,3 +56,36 @@ not identical behaviour regardless of the platform on which their software is
built, relieving them of the need to code special-case conditions to work
around or take advantage of platform-specific deficiencies or features.")
(license asl2.0)))
+
+(define-public libaprutil
+ (package
+ (name "libaprutil")
+ (version "1.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://apache.crihan.fr/dist//apr/apr-util-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "0832cb90zd7zqhhdx0v3i8viw1rmn0d945qbk1zid3cnky9r0s19"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libapr" ,libapr)))
+ (arguments
+ '(#:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (libapr (assoc-ref inputs "libapr")))
+ (setenv "CONFIG_SHELL" (which "bash"))
+ (zero?
+ (system* "./configure"
+ (string-append "--prefix=" out)
+ (string-append "--with-apr=" libapr)))))
+ %standard-phases)))
+ (home-page "http://apr.apache.org/")
+ (synopsis "One of the Apache Portable Runtime Library companions")
+ (description
+ "APR-util provides a number of helpful abstractions on top of APR.")
+ (license asl2.0)))