summaryrefslogtreecommitdiff
path: root/gnu/packages/libbsd.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-26 17:46:10 +0200
committerMarius Bakke <marius@gnu.org>2022-06-26 22:58:34 +0200
commite4496bf373c81d73e4709d2c16048460dbf58866 (patch)
tree29d4f4b82f396e79a6e979737c36de181162ab01 /gnu/packages/libbsd.scm
parentcac8545b023436bbf31fa74832a6d8954a25eb8f (diff)
gnu: libbsd: Update to 0.11.6.
* gnu/packages/libbsd.scm (libbsd): Update to 0.11.6. [arguments]: Add #:phases. [inputs]: Add LIBMD.
Diffstat (limited to 'gnu/packages/libbsd.scm')
-rw-r--r--gnu/packages/libbsd.scm22
1 files changed, 18 insertions, 4 deletions
diff --git a/gnu/packages/libbsd.scm b/gnu/packages/libbsd.scm
index 16a7e8fd89..9759d1b5ad 100644
--- a/gnu/packages/libbsd.scm
+++ b/gnu/packages/libbsd.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,22 +21,35 @@
#:use-module (guix build-system gnu)
#:use-module (guix download)
#:use-module (guix licenses)
- #:use-module (guix packages))
+ #:use-module (guix packages)
+ #:use-module (guix gexp)
+ #:use-module (gnu packages crypto))
(define-public libbsd
(package
(name "libbsd")
- (version "0.10.0")
+ (version "0.11.6")
(source (origin
(method url-fetch)
(uri (string-append "https://libbsd.freedesktop.org/releases/"
"libbsd-" version ".tar.xz"))
(sha256
(base32
- "11x8q45jvjvf2dvgclds64mscyg10lva33qinf2hwgc84v3svf1l"))))
+ "1pxmk42brddk43bj8lp4a64f9iwhc5ii91y6w7k97xpaf8qqzcqr"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--disable-static")))
+ (list #:configure-flags #~'("--disable-static")
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'check 'disable-pwcache-test
+ (lambda _
+ ;; This test expects the presence of a root
+ ;; user and group, which do not exist in the
+ ;; build container.
+ (substitute* "test/Makefile"
+ (("pwcache\\$\\(EXEEXT\\) ")
+ "")))))))
+ (inputs
+ (list libmd))
(synopsis "Utility functions from BSD systems")
(description "This library provides useful functions commonly found on BSD
systems, and lacking on others like GNU systems, thus making it easier to port