summaryrefslogtreecommitdiff
path: root/gnu/packages/libevent.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-10-23 15:18:26 +0200
committerLudovic Courtès <ludo@gnu.org>2022-10-23 15:56:19 +0200
commit3734857fc55df2c599c2fe5cc4ae49f5d47879fc (patch)
tree1b2a0532cc5c92e5e3ae961e867abb2b0d5bdfd7 /gnu/packages/libevent.scm
parentd117d225d99a99984b4cce082f5f1bdd18efc003 (diff)
gnu: libevent: Prefix (guix licenses) bindings.
* gnu/packages/libevent.scm: Import (guix licenses) with the 'license:' prefix.
Diffstat (limited to 'gnu/packages/libevent.scm')
-rw-r--r--gnu/packages/libevent.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 680db44707..176e66cf42 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -26,7 +26,7 @@
(define-module (gnu packages libevent)
#:use-module (gnu packages)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -74,7 +74,7 @@ libevent is meant to replace the event loop found in event driven
network servers. An application just needs to call event_dispatch() and
then add or remove events dynamically without having to change the event
loop.")
- (license bsd-3)))
+ (license license:bsd-3)))
(define-public libevent-with-openssl
(package/inherit libevent
@@ -108,8 +108,7 @@ loosely modelled after libevent. It includes relative timers, absolute timers
with customized rescheduling, synchronous signals, process status change
events, event watchers dealing with the event loop itself, file watchers, and
limited support for fork events.")
- (license
- (list bsd-2 gpl2+))))
+ (license (list license:bsd-2 license:gpl2+))))
(define-public libuv
(package
@@ -140,7 +139,7 @@ resolution, asynchronous file system operations, and threading primitives.")
;; A few files fall under other non-copyleft licenses; see 'LICENSE' for
;; details. Documentation is CC-BY 4.0 as of 1.12.0; see 'LICENSE-docs'.
- (license (list expat cc-by4.0))))
+ (license (list license:expat license:cc-by4.0))))
(define-public libuv-for-node
;; When upgrading Node, also upgrade this. Get the version from
@@ -227,7 +226,7 @@ Currently supported event loops are EV, Event, Glib/Gtk2, Tk, Qt,
@code{Event::Lib}, Irssi, @code{IO::Async} and POE (and thus also WxWidgets
and Prima). It also comes with a very fast Pure Perl event loop that does
not rely on XS.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-ev
(package
@@ -268,7 +267,7 @@ not rely on XS.")
"This module provides an interface to @code{libev}, a high performance
full-featured event loop. It can be used through the @code{AnyEvent} module
and still be faster than other event loops currently supported in Perl.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-rpc-epc-service
(package
@@ -295,4 +294,4 @@ and still be faster than other event loops currently supported in Perl.")
(synopsis "Asynchronous remote procedure stack")
(description "RPC::EPC::Service enables to connect the other process with
the S-expression protocol, like the Swank protocol of the SLIME.")
- (license perl-license)))
+ (license license:perl-license)))