summaryrefslogtreecommitdiff
path: root/gnu/packages/libevent.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-01-30 20:26:55 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-01 02:42:12 +0100
commite8fc1a0dcf6901f19f26e5277ed32d626c20cf08 (patch)
tree327ebe06065a4e6058e69d0cb75fc5e79aeedc9f /gnu/packages/libevent.scm
parentf1a892c96f15f834f498a35cfa7b36069c640f52 (diff)
gnu: libevent: Update to 2.1.8 [security fixes].
* gnu/packages/libevent.scm (libevent): Update to 2.1.8. [inputs]: Change 'python-wrapper' to 'python-2'. Move 'which' to ... [native-inputs]: ... here. New field. (libevent-2.0): New variable. * gnu/packages/patches/libevent-2.1-dns-tests.patch, gnu/packages/patches/libevent-2.0-evdns-fix-remote-stack-overread.patch gnu/packages/patches/libevent-2.0-evdns-fix-searching-empty-hostnames.patch gnu/packages/patches/libevent-2.0-evutil-fix-buffer-overflow.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/gnuzilla.scm (icecat)[inputs]: Change 'libevent' to 'libevent-2.0'.
Diffstat (limited to 'gnu/packages/libevent.scm')
-rw-r--r--gnu/packages/libevent.scm31
1 files changed, 25 insertions, 6 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index cb76915ef7..ca59db390c 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
+;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,7 +34,7 @@
(define-public libevent
(package
(name "libevent")
- (version "2.0.22")
+ (version "2.1.8")
(source (origin
(method url-fetch)
(uri (string-append
@@ -41,13 +42,13 @@
version "-stable/libevent-" version "-stable.tar.gz"))
(sha256
(base32
- "18qz9qfwrkakmazdlwxvjmw8p76g70n3faikwvdwznns1agw9hki"))
- (patches (search-patches "libevent-dns-tests.patch"))))
+ "1hhxnxlr0fsdv7bdmzsnhdz16fxf3jg2r6vyljcl3kj6pflcap4n"))
+ (patches (search-patches "libevent-2.1-dns-tests.patch"))))
(build-system gnu-build-system)
(inputs
- `(;; Dependencies used for the tests and for `event_rpcgen.py'.
- ("which" ,which)
- ("python" ,python-wrapper)))
+ `(("python" ,python-2))) ; for 'event_rpcgen.py'
+ (native-inputs
+ `(("which" ,which)))
(home-page "http://libevent.org/")
(synopsis "Event notification library")
(description
@@ -62,6 +63,24 @@ then add or remove events dynamically without having to change the event
loop.")
(license bsd-3)))
+(define-public libevent-2.0
+ (package
+ (inherit libevent)
+ (version "2.0.22")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/libevent/libevent/releases/download/release-"
+ version "-stable/libevent-" version "-stable.tar.gz"))
+ (sha256
+ (base32
+ "18qz9qfwrkakmazdlwxvjmw8p76g70n3faikwvdwznns1agw9hki"))
+ (patches (search-patches
+ "libevent-dns-tests.patch"
+ "libevent-2.0-evdns-fix-remote-stack-overread.patch"
+ "libevent-2.0-evutil-fix-buffer-overflow.patch"
+ "libevent-2.0-evdns-fix-searching-empty-hostnames.patch"))))))
+
(define-public libev
(package
(name "libev")