summaryrefslogtreecommitdiff
path: root/gnu/packages/libffi.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-14 03:00:15 +0200
committerMarius Bakke <marius@gnu.org>2022-07-16 18:32:12 +0200
commit32b7e12e77d58ed67c1a3c3123f01e487b660dbd (patch)
treef4f4bb6fbe1fda78a7210608d1132994e5231d43 /gnu/packages/libffi.scm
parent4442a5db773f79e05c37e014c63b4298e7de666b (diff)
gnu: python-cffi: Update to 1.15.1.
* gnu/packages/libffi.scm (python-cffi): Update to 1.15.1. (python-cffi-1.15): Remove variable.
Diffstat (limited to 'gnu/packages/libffi.scm')
-rw-r--r--gnu/packages/libffi.scm16
1 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index 701feeb773..c37baaf056 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -82,13 +82,13 @@ conversions for values passed between the two languages.")
(define-public python-cffi
(package
(name "python-cffi")
- (version "1.14.4")
+ (version "1.15.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cffi" version))
(sha256
- (base32 "0v080s7vlrjz9z823x2yh36yc8drwpvvir6w8wfkkzd7k2z5qihs"))))
+ (base32 "1y9lr651svbzf1m03s4lqbnbv2byx8f6f0ml7hjm24vvlfwvy06l"))))
(build-system python-build-system)
(inputs
(list libffi))
@@ -140,18 +140,6 @@ conversions for values passed between the two languages.")
(description "Foreign Function Interface for Python calling C code.")
(license expat)))
-;; TODO(staging): Merge with the above.
-(define-public python-cffi-1.15
- (package
- (inherit python-cffi)
- (version "1.15.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "cffi" version))
- (sha256
- (base32 "0m3rz2pqfmyfagx0bhj2jlbr2h58j3wr3cyv1agxkhlnm1k0s3wj"))))))
-
(define-public python-cffi-documentation
(package
(name "python-cffi-documentation")