summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-11-27 08:37:32 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-11-27 21:02:43 +0100
commit7de565657151a8531f6a62e4a83744b690dcb864 (patch)
treeb36a58aed4d47ef590a5559617453150ea002b71 /gnu/packages/libreoffice.scm
parent3423d32838ab159904ae02eda95df069d338592e (diff)
gnu: Add dragonbox.
* gnu/packages/libreoffice.scm (dragonbox): New variable.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index d7db573013..7c1af81bae 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -30,6 +30,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages libreoffice)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
@@ -1093,6 +1094,30 @@ and to return information on pronunciations, meanings and synonyms.")
converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
(license license:mpl2.0)))
+(define-public dragonbox
+ (package
+ (name "dragonbox")
+ (version "1.1.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jk-jeon/dragonbox")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qxx94s2kfgnlnyl1gwmbxkksr3dipvb99zdyi5skw3z2bq563sa"))))
+ (build-system cmake-build-system)
+ (arguments (list #:tests? #false)) ;no test target
+ (home-page "https://github.com/jk-jeon/dragonbox")
+ (synopsis "Float-to-string conversion algorithm")
+ (description "Dragonbox generates a pair of integers from a floating-point
+number: the decimal significand and the decimal exponent of the input
+floating-point number. These integers can then be used for string generation
+of decimal representation of the input floating-point number, the procedure
+commonly called @code{ftoa} or @code{dtoa}.")
+ (license license:asl2.0)))
+
(define dtoa
(origin
(method url-fetch)