summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-02-13 13:17:15 -0500
committerMark H Weaver <mhw@netris.org>2018-02-13 13:17:15 -0500
commit288b8fd5e97c32d44a49612dbeef854c05ebc373 (patch)
tree8a5021c9af2497c560ff94d37b8217d6187d8dbd /gnu/packages/libreoffice.scm
parenta7fb29866520d5661e0ac8e47957c91a2a43e11e (diff)
parentacff6aa00473befac75f8120fc4299f4f265c258 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm70
1 files changed, 31 insertions, 39 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 3c04ba8c49..9b60c06a8d 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;;
;;; This file is part of GNU Guix.
@@ -54,6 +54,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gperf)
+ #:use-module (gnu packages gnupg)
#:use-module (gnu packages gnuzilla)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
@@ -839,22 +840,10 @@ and to return information on pronunciations, meanings and synonyms.")
(license (non-copyleft "file://COPYING"
"See COPYING in the distribution."))))
-;; LibreOffice requires an xmlsec source tarball; it does not even check
-;; for the presence of an externally compiled library.
-(define xmlsec-src-libreoffice
- (origin
- (method url-fetch)
- (uri
- (string-append
- "http://dev-www.libreoffice.org/src/"
- "86b1daaa438f5a7bea9a52d7b9799ac0-xmlsec1-1.2.23.tar.gz"))
- (sha256 (base32
- "17qfw5crkqn4v6xbkjxrjvcccfc00dy053892wrwv54qdk8n7m21"))))
-
(define-public libreoffice
(package
(name "libreoffice")
- (version "5.3.7.2")
+ (version "5.4.5.1")
(source
(origin
(method url-fetch)
@@ -863,16 +852,11 @@ and to return information on pronunciations, meanings and synonyms.")
"https://download.documentfoundation.org/libreoffice/src/"
(version-prefix version 3) "/libreoffice-" version ".tar.xz"))
(sha256 (base32
- "0z7fssp0jcj09wxad1wmhy69n71a2mwl933lxp9dz5sdvzncxmy3"))))
+ "167bh6jgyhfcvn3g7xghkg4nb99h91diypdlry5df21xs8bis5gb"))))
(build-system gnu-build-system)
(native-inputs
- `(;; autoreconf is run by the LibreOffice build system, since after
- ;; unpacking the external xmlsec tarball, it applies a series of
- ;; patches to Makefile.am, configure.in, config.guess and config.sub.
- ("autoconf" ,autoconf)
- ("automake" ,automake)
- ("bison" ,bison)
- ("cppunit" ,cppunit)
+ `(("bison" ,bison)
+ ("cppunit" ,cppunit-1.14)
("flex" ,flex)
("pkg-config" ,pkg-config)
("python" ,python-wrapper)
@@ -888,6 +872,7 @@ and to return information on pronunciations, meanings and synonyms.")
("glew" ,glew)
("glm" ,glm)
("gperf" ,gperf)
+ ("gpgme" ,gpgme)
("graphite2" ,graphite2)
("gst-plugins-base" ,gst-plugins-base)
("gtk+" ,gtk+)
@@ -897,12 +882,14 @@ and to return information on pronunciations, meanings and synonyms.")
("libabw" ,libabw)
("libcdr" ,libcdr)
("libcmis" ,libcmis)
- ("libjpeg" ,libjpeg)
+ ("libjpeg-turbo" ,libjpeg-turbo)
("libe-book" ,libe-book)
("libetonyek" ,libetonyek)
("libexttextcat" ,libexttextcat)
("libfreehand" ,libfreehand)
("liblangtag" ,liblangtag)
+ ;; XXX: Perhaps this should be propagated from xmlsec.
+ ("libltdl" ,libltdl)
("libmspub" ,libmspub)
("libmwaw" ,libmwaw)
("libodfgen" ,libodfgen)
@@ -935,7 +922,7 @@ and to return information on pronunciations, meanings and synonyms.")
("unixodbc" ,unixodbc)
("unzip" ,unzip)
("vigra" ,vigra)
- ("xmlsec-src" ,xmlsec-src-libreoffice)
+ ("xmlsec" ,xmlsec-nss)
("zip" ,zip)))
(arguments
`(#:tests? #f ; Building the tests already fails.
@@ -944,7 +931,7 @@ and to return information on pronunciations, meanings and synonyms.")
(modify-phases %standard-phases
(add-before 'configure 'prepare-src
(lambda* (#:key inputs #:allow-other-keys)
- (let ((xmlsec (assoc-ref inputs "xmlsec-src")))
+ (let ((gpgme (assoc-ref inputs "gpgme")))
(substitute*
"sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx"
;; This header was renamed in Poppler 0.62.0.
@@ -956,20 +943,21 @@ and to return information on pronunciations, meanings and synonyms.")
"solenv/gbuild/gbuild.mk"
"solenv/gbuild/platform/unxgcc.mk")
(("/bin/sh") (which "sh")))
- (mkdir "external/tarballs")
- (symlink
- xmlsec
- (string-append "external/tarballs/"
- "86b1daaa438f5a7bea9a52d7b9799ac0-"
- "xmlsec1-1.2.23.tar.gz"))
- ;; The following is required for building xmlsec from the
- ;; unpatched external tarball; since "configure" starts with
- ;; "/bin/sh", it needs to be executed by a command invoking
- ;; the shell.
- (setenv "SHELL" (which "bash"))
- (setenv "CONFIG_SHELL" (which "bash"))
- (substitute* "external/libxmlsec/ExternalProject_xmlsec.mk"
- (("./configure") "$(CONFIG_SHELL) ./configure" ))
+
+ ;; GPGME++ headers are installed in a gpgme++ subdirectory,
+ ;; but files in "xmlsecurity/source/gpg/" expect to find them
+ ;; on the include path without a prefix.
+ (substitute* "xmlsecurity/Library_xsec_xmlsec.mk"
+ (("\\$\\$\\(INCLUDE\\)")
+ (string-append "$$(INCLUDE) -I" gpgme "/include/gpgme++")))
+
+ ;; XXX: When GTK2 is disabled, one header file is not included.
+ ;; This is likely fixed in later versions. See also
+ ;; <https://bugs.gentoo.org/641812>.
+ (substitute* "vcl/unx/gtk3/gtk3gtkframe.cxx"
+ (("#include <unx/gtk/gtkgdi.hxx>")
+ "#include <unx/gtk/gtkgdi.hxx>\n#include <unx/gtk/gtksalmenu.hxx>"))
+
#t)))
(add-after 'install 'bin-and-desktop-install
;; Create 'soffice' and 'libreoffice' symlinks to the executable
@@ -1043,6 +1031,10 @@ and to return information on pronunciations, meanings and synonyms.")
"--disable-coinmp"
"--disable-firebird-sdbc" ; embedded firebird
"--disable-gltf"
+ ;; XXX: PDFium support requires fetching an external tarball and
+ ;; patching the build scripts to work with GCC5. Try enabling this
+ ;; when our default compiler is >=GCC 6.
+ "--disable-pdfium"
"--disable-gtk" ; disable use of GTK+ 2
"--without-doxygen")))
(home-page "https://www.libreoffice.org/")