summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-01-05 16:09:27 -0600
committerLudovic Courtès <ludo@gnu.org>2016-01-12 21:07:53 +0100
commitc91d3fb7f4f754b56b540d8556d6a3ce6085ef37 (patch)
tree89c7d1ff32dcf730de4c26033b8ea1786395129e /gnu/packages/libreoffice.scm
parent3abe8136fddf5bed75219bcb8a552004f078560a (diff)
gnu: boost: Update to 1.60.0.
* gnu/packages/boost.scm (boost): Update to 1.60.0. [source]: Remove patch. * gnu/packages/patches/boost-mips-avoid-m32.patch: Delete patch * gnu-system.am (dist_patch_DATA): Remove patch. Also fix dependent packages: * gnu/packages/patches/csound-header-ordering.patch: New patch. * gnu/packages/audio.scm (csound)[source]: Use it. [arguments]: Add 'set-flags phase. * gnu/packages/patches/libcmis-fix-test-onedrive.patch: New patch. * gnu/packages/libreoffice.scm (libcmis)[source]: Use it. (libreoffice)[arguments]: Add LDFLAGS to #:configure-flags. (librevenge)[inputs]: Move boost from here... [propogated-inputs]: to here. [arguments]: Add LDFLAGS to #:configure-flags. * gnu/packages/patches/openimageio-boost-1.60.patch: New patch. * gnu/packages/graphics.scm (openimageio): Use it. * gnu-system.am (dist_patch_DATA): Add patches.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 7496a6c8b9..a82cde7d0a 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -25,6 +25,7 @@
non-copyleft x11-style))
#:use-module (guix packages)
#:use-module (guix utils)
+ #:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
@@ -130,15 +131,18 @@ CSV, CSS and XML.")
"03ygxyb0vfjv8raif5q62sl33b54wkr5rzgadb8slijm6k281wpn"))))
(build-system gnu-build-system)
(native-inputs
- `(("boost" ,boost)
- ("cppunit" ,cppunit)
+ `(("cppunit" ,cppunit)
("doxygen" ,doxygen)
("pkg-config" ,pkg-config)))
(inputs
`(("zlib" ,zlib)))
+ (propagated-inputs ; Referenced by .la files
+ `(("boost" ,boost)))
(arguments
;; avoid triggering configure errors by simple inclusion of boost headers
- `(#:configure-flags '("--disable-werror")))
+ `(#:configure-flags '("--disable-werror"
+ ;; Avoid undefined library references
+ "LDFLAGS=-lboost_system")))
(home-page "http://sourceforge.net/p/libwpd/wiki/librevenge/")
(synopsis "Document importer for office suites")
(description "Librevenge is a base library for writing document import
@@ -244,7 +248,8 @@ working with graphics in the WPG (WordPerfect Graphics) format.")
(uri (string-append "mirror://sourceforge/" name "/" name "-"
version ".tar.gz"))
(sha256 (base32
- "1dprvk4fibylv24l7gr49gfqbkfgmxynvgssvdcycgpf7n8h4zm8"))))
+ "1dprvk4fibylv24l7gr49gfqbkfgmxynvgssvdcycgpf7n8h4zm8"))
+ (patches (list (search-patch "libcmis-fix-test-onedrive.patch")))))
(build-system gnu-build-system)
(native-inputs
`(("cppunit" ,cppunit)
@@ -805,6 +810,8 @@ and to return information on pronunciations, meanings and synonyms.")
"--with-system-libs" ; enable all --with-system-* flags
(string-append "--with-boost-libdir="
(assoc-ref %build-inputs "boost") "/lib")
+ ;; Avoid undefined symbols required by boost::spirit
+ "LDFLAGS=-lboost_system"
;; Avoid a dependency on ucpp.
"--with-idlc-cpp=cpp"
;; The fonts require an external tarball (crosextrafonts).