summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2023-05-10 18:39:22 +0200
committerLudovic Courtès <ludo@gnu.org>2023-05-18 19:51:06 +0200
commit255b5b81db3e50a64dfd722981985617615430f0 (patch)
treedbcaeb86746c1f28efe6a973bd9465c267da1fb9 /gnu/packages/linux.scm
parentc95e817bb986c49fd0d2a8896c2e63782f05a7f7 (diff)
gnu: btrfs-progs: Run 'guix style' over the package.
* gnu/packages/linux.scm (btrfs-progs): Restyle. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm60
1 files changed, 32 insertions, 28 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c38287e16b..79809c33fb 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -66,7 +66,7 @@
;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2022 Rene Saavedra <nanuui@protonmail.com>
;;; Copyright © 2022 muradm <mail@muradm.net>
-;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2022, 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2022 Hunter Jozwiak <hunter.t.joz@gmail.com>
;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2022 Stefan <stefan-guix@vodafonemail.de>
@@ -5917,14 +5917,13 @@ and copy/paste text in the console and in xterm.")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/kernel/"
- "people/kdave/btrfs-progs/"
- "btrfs-progs-v" version ".tar.xz"))
+ "people/kdave/btrfs-progs/" "btrfs-progs-v"
+ version ".tar.xz"))
(sha256
(base32
"0ylxszcsm0jqsa5glccd1pv3rcfk1f5wjcf3ayxc0r9xgzcngrkb"))))
(build-system gnu-build-system)
- (outputs '("out"
- "static")) ; static versions of the binaries in "out"
+ (outputs '("out" "static")) ;static versions of the binaries in "out"
(arguments
'(#:configure-flags
;; The ‘Python support’ was never actually installed by previous
@@ -5937,29 +5936,33 @@ and copy/paste text in the console and in xterm.")
(("\\$\\(DESTDIR\\)\\$\\(udevruledir\\)")
(string-append (assoc-ref outputs "out")
"/lib/udev/rules.d")))))
- (add-after 'build 'build-static
- (lambda _ (invoke "make" "static")))
- (add-after 'install 'install-bash-completion
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bashcomp (string-append out "/etc/bash_completion.d")))
- (mkdir-p bashcomp)
- (copy-file "btrfs-completion"
- (string-append bashcomp "/btrfs")))))
- (add-after 'install 'install-static
- (let ((staticbin (string-append (assoc-ref %outputs "static")
- "/bin")))
- (lambda _
- (invoke "make"
- (string-append "bindir=" staticbin)
- "install-static")))))
- #:tests? #f ; XXX: require the 'btrfs' kernel module.
+ (add-after 'build 'build-static
+ (lambda _
+ (invoke "make" "static")))
+ (add-after 'install 'install-bash-completion
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bashcomp (string-append out
+ "/etc/bash_completion.d")))
+ (mkdir-p bashcomp)
+ (copy-file "btrfs-completion"
+ (string-append bashcomp "/btrfs")))))
+ (add-after 'install 'install-static
+ (let ((staticbin (string-append (assoc-ref %outputs
+ "static")
+ "/bin")))
+ (lambda _
+ (invoke "make"
+ (string-append "bindir=" staticbin)
+ "install-static")))))
+ #:tests? #f ;XXX: require the 'btrfs' kernel module.
#:test-target "test"
- #:parallel-tests? #f)) ; tests fail when run in parallel
- (inputs `(("e2fsprogs" ,e2fsprogs) ; for btrfs-convert
+ #:parallel-tests? #f)) ;tests fail when run in parallel
+ (inputs `(("e2fsprogs" ,e2fsprogs)
+ ;for btrfs-convert
("eudev" ,eudev)
("lzo" ,lzo)
- ("util-linux:lib" ,util-linux "lib") ;for libblkid and libuuid
+ ("util-linux:lib" ,util-linux "lib") ;for libblkid and libuuid
("util-linux:static" ,util-linux "static") ;ditto
("zlib" ,zlib)
("zlib:static" ,zlib "static")
@@ -5971,14 +5974,15 @@ and copy/paste text in the console and in xterm.")
;; For tests.
("acl" ,acl)
("dmsetup" ,lvm2)
- ("grep" ,grep) ; need Perl regexp support
+ ("grep" ,grep) ;need Perl regexp support
("libaio" ,libaio)
("liburing" ,liburing)
- ("util-linux" ,util-linux) ; for fallocate
+ ("util-linux" ,util-linux) ;for fallocate
("which" ,which)))
(home-page "https://btrfs.wiki.kernel.org/index.php/Main_Page")
(synopsis "Create and manage btrfs copy-on-write file systems")
- (description "Btrfs is a @acronym{CoW, copy-on-write} file system for Linux
+ (description
+ "Btrfs is a @acronym{CoW, copy-on-write} file system for Linux
aimed at implementing advanced features while focusing on fault tolerance,
repair and easy administration.")
;; GPL2+: crc32.c, radix-tree.c, raid6.c, rbtree.c.