summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-07-27 19:36:46 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-07-27 19:36:46 +0300
commit35c8d631d2bd63c64e863b5509f29fdcb7f856e6 (patch)
tree41910bc264e3ba06f21f03c9da8d458fe2f737af /gnu/packages/linux.scm
parentc7e45139faa27b60f2c7d0a4bc140f9793d97d47 (diff)
gnu: linux-libre-arm64-generic: Add support for ath9k wireless.
* gnu/packages/linux.scm (linux-libre-arm64-generic)[extra-options): Add configuration for ath9k_htc.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 250e26cf09..e41027d920 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1291,7 +1291,9 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
#:extra-version "arm64-generic"
#:extra-options
(append
- `(;; needed to fix the RTC on rockchip platforms
+ `(;; Provide support for ath9k wireless
+ ("CONFIG_ATH9K_HTC" . m)
+ ;; needed to fix the RTC on rockchip platforms
("CONFIG_RTC_DRV_RK808" . #t)
;; Pinebook display, battery, charger and usb
("CONFIG_DRM_ANALOGIX_ANX6345" . m)