summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 23:43:40 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
commit76e041f9eef85bb039c5251d3350c62ee2066883 (patch)
tree17f0b7e6a1e5be339ed4be3fee0913e8a57ae074 /gnu/packages/linux.scm
parent7a56d216fce4f0fe726c12d8856628bc3464f9d5 (diff)
gnu: lvm2: Update to 2.03.21.
* gnu/packages/linux.scm (lvm2): Update to 2.03.21. [source]: Remove patch. Don't explicitly return #t from snippet. [arguments]: Don't explicitly return #t from phases. * gnu/packages/patches/lvm2-static-link.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index aabbc7fc17..250e26cf09 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4455,7 +4455,7 @@ one to send arbitrary keycodes when a given key is tapped or held.")
(define-public lvm2
(package
(name "lvm2")
- (version "2.03.11")
+ (version "2.03.21")
(source (origin
(method url-fetch)
(uri (list (string-append "https://sourceware.org/ftp/lvm2/LVM2."
@@ -4464,7 +4464,7 @@ one to send arbitrary keycodes when a given key is tapped or held.")
version ".tgz")))
(sha256
(base32
- "1m4xpda8vbyd89ca0w8nacvnl4j34yzsa625gn990fb5sh84ab44"))
+ "0zksqsz8y47kh6vq0ykkgxf19il4wxfn234n6zf8m691sqhij9hy"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -4475,9 +4475,7 @@ one to send arbitrary keycodes when a given key is tapped or held.")
(("^confdir = .*$")
"confdir = @sysconfdir@\n")
(("DEFAULT_SYS_DIR = @DEFAULT_SYS_DIR@")
- "DEFAULT_SYS_DIR = @sysconfdir@"))
- #t))
- (patches (search-patches "lvm2-static-link.patch"))))
+ "DEFAULT_SYS_DIR = @sysconfdir@"))))))
(build-system gnu-build-system)
(native-inputs
(list config
@@ -4503,8 +4501,7 @@ one to send arbitrary keycodes when a given key is tapped or held.")
(setenv "SHELL" (which "sh"))
;; Replace /bin/sh with the right file name.
- (patch-makefile-SHELL "make.tmpl")
- #t)))
+ (patch-makefile-SHELL "make.tmpl"))))
#:configure-flags (list (string-append "--sysconfdir="
(assoc-ref %outputs "out")