summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-02 12:27:14 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-02 14:32:03 +0300
commitb62c9fbdd3f706f8bcf70d92807184e507603ec5 (patch)
tree2b1a16ca6c660223501246aab0c629560297c1c5 /gnu/packages/linux.scm
parent44d70440944aa47e5f37493346e560f38907d777 (diff)
gnu: libaio: Fix building on riscv64-linux.
* gnu/packages/linux.scm (libaio)[arguments]: When building for riscv64-linux add a patch to account for undeclared behavior. [native-inputs]: Add patch file, patch. * gnu/packages/patches/libaio-riscv-test5.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index de676500c6..f322c31df8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5621,7 +5621,20 @@ Linux Device Mapper multipathing driver:
#:test-target "partcheck" ; need root for a full 'check'
#:phases
#~(modify-phases %standard-phases
- (delete 'configure)))) ; no configure script
+ (delete 'configure) ; no configure script
+ #$@(if (target-riscv64?)
+ #~((add-after 'unpack 'patch-test
+ (lambda* (#:key build-inputs #:allow-other-keys)
+ (invoke "patch" "-p1" "-i"
+ #$(local-file
+ (search-patch
+ "libaio-riscv-test5.patch"))))))
+ #~()))))
+ (native-inputs
+ (if (target-riscv64?)
+ (list (search-patch "libaio-riscv-test5.patch")
+ patch)
+ '()))
(home-page "https://pagure.io/libaio")
(synopsis "Linux-native asynchronous I/O access library")
(description