summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTomas Volf <~@wolfsden.cz>2024-02-13 17:22:09 +0100
committerLeo Famulari <leo@famulari.name>2024-02-20 20:32:50 -0500
commitb6f82b9ef1a3d51a39995598eab9f793656e9123 (patch)
tree0d0ea2ceff3d6e8bfa2b6145d1c823655262a704 /gnu/packages/linux.scm
parent3bc2a7d0edc6e4f38631f11fe8b51e6e42926a20 (diff)
gnu: linux-libre-documentation: Fix compilation.
When compiling linux-libre-documentation@6.6.16, the compilation fails with following error message: ------ Exception occurred: File "/tmp/guix-build-linux-libre-documentation-6.6.16.drv-0/linux-6.6.16/Documentation/sphinx/kernel_feat.py", line 112, in run nodeList = self.nestedParse(out_lines, fname) UnboundLocalError: local variable 'fname' referenced before assignment ------ This is already fixed upstream[0], so this commit backports the change. 0: https://lore.kernel.org/all/20240206054907.066a0325@coco.lan/t/ * gnu/packages/linux.scm (linux-libre-documentation): Apply patch fixing compilation. Change-Id: Ic96f14aa25df09f38e029ca70d2647cbf37c2365 Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 932685ef68..339add4d82 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2004,6 +2004,17 @@ GnuPG-based password manager like @code{pass}.")
(package
(inherit linux-libre)
(name "linux-libre-documentation")
+ (source
+ (origin
+ (inherit linux-libre-source)
+ (patches
+ (list
+ (origin
+ (method url-fetch)
+ (uri "https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/patch/Documentation/sphinx/kernel_feat.py?id=c23de7ceae59e4ca5894c3ecf4f785c50c0fa428")
+ (sha256
+ (base32
+ "0inw2pl7nh82sw8bhvvzqa61552bisl78yc1nyl2x6dmpyppzrld")))))))
(arguments
(list
#:tests? #f