summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-04-18 20:27:14 -0400
committerLeo Famulari <leo@famulari.name>2023-05-16 13:15:13 -0400
commitc8e599b9391f789a8a3e2183fc8f0c2a5061ceb0 (patch)
tree45166d4c75d7e10ddbdf5a0e6c95c0ed90fcae6c /gnu/packages/linux.scm
parent66ecffbeba0685ff2f1071db8aeb2393986afb97 (diff)
gnu: Add linux-libre 6.3.
* gnu/packages/linux.scm (linux-libre-6.3-version, linux-libre-6.3-gnu-revision, deblob-scripts-6.3, linux-libre-6.3-pristine-source, linux-libre-6.3-source, linux-libre-headers-6.3, linux-libre-6.3): New variables. * gnu/packages/aux-files/linux-libre/6.3-arm.conf, gnu/packages/aux-files/linux-libre/6.3-arm64.conf, gnu/packages/aux-files/linux-libre/6.3-i686.conf, gnu/packages/aux-files/linux-libre/6.3-x86_64.conf: New files. * Makefile.am (AUX_FILES): Add them.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 90c1adde53..c38287e16b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -485,6 +485,21 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; The current "stable" kernels. That is, the most recently released major
;; versions that are still supported upstream.
+(define-public linux-libre-6.3-version "6.3.2")
+(define-public linux-libre-6.3-gnu-revision "gnu")
+(define deblob-scripts-6.3
+ (linux-libre-deblob-scripts
+ linux-libre-6.3-version
+ linux-libre-6.3-gnu-revision
+ (base32 "01ivgzq18fwas87q84jx9jipcw58kwdnch7ylwg06d98ncga27px")
+ (base32 "1m3zvklfmxh4fgc7lvkgpsyfcqzqccvivhmbwbzsvyzzalg7bv4f")))
+(define-public linux-libre-6.3-pristine-source
+ (let ((version linux-libre-6.3-version)
+ (hash (base32 "0a2kki763lrlafh6kf9ca8nxrdrk5043k7vdzy4pjgyahbrfq4mn")))
+ (make-linux-libre-source version
+ (%upstream-linux-source version hash)
+ deblob-scripts-6.3)))
+
(define-public linux-libre-6.2-version "6.2.15")
(define-public linux-libre-6.2-gnu-revision "gnu")
(define deblob-scripts-6.2
@@ -621,6 +636,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(patches (append (origin-patches source)
patches))))
+(define-public linux-libre-6.3-source
+ (source-with-patches linux-libre-6.3-pristine-source
+ (list %boot-logo-patch
+ %linux-libre-arm-export-__sync_icache_dcache-patch)))
+
(define-public linux-libre-6.2-source
(source-with-patches linux-libre-6.2-pristine-source
(list %boot-logo-patch
@@ -737,6 +757,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(description "Headers of the Linux-Libre kernel.")
(license license:gpl2)))
+(define-public linux-libre-headers-6.3
+ (make-linux-libre-headers* linux-libre-6.3-version
+ linux-libre-6.3-gnu-revision
+ linux-libre-6.3-source))
+
(define-public linux-libre-headers-6.2
(make-linux-libre-headers* linux-libre-6.2-version
linux-libre-6.2-gnu-revision
@@ -1080,6 +1105,14 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
;;; Generic kernel packages.
;;;
+(define-public linux-libre-6.3
+ (make-linux-libre* linux-libre-6.3-version
+ linux-libre-6.3-gnu-revision
+ linux-libre-6.3-source
+ '("x86_64-linux" "i686-linux" "armhf-linux"
+ "aarch64-linux" "powerpc64le-linux" "riscv64-linux")
+ #:configuration-file kernel-config))
+
(define-public linux-libre-6.2
(make-linux-libre* linux-libre-6.2-version
linux-libre-6.2-gnu-revision