summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-10 19:38:48 +0200
committerMarius Bakke <marius@gnu.org>2022-08-11 00:21:10 +0200
commitd8d4b81147df59542385a79191eb51e3568ae309 (patch)
tree5262decfb0e90a5e7f2cbd94a16e89ede6d17e8a /gnu/packages/linux.scm
parentaacbe59fbceb8a93ecb68fed8581dfdd70dafc11 (diff)
gnu: fuse@2: Prepare for newer glibc.
* gnu/packages/patches/fuse-glibc-2.34.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/linux.scm (fuse)[source](patches): Add the patch. [arguments]: Add force-bootstrap phase. [native-inputs]: Add AUTOCONF, AUTOMAKE, GETTEXT-MINIMAL, and LIBTOOL.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b868991461..9bfa1951be 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3291,8 +3291,11 @@ or kill them altogether.")
(sha256
(base32
"1ddlq6kzxilccgbvxjfx80jx6kamgw4sv49phks2zhlcc1frvrnh"))
- (patches (search-patches "fuse-overlapping-headers.patch"))))
+ (patches (search-patches "fuse-overlapping-headers.patch"
+ "fuse-glibc-2.34.patch"))))
(build-system gnu-build-system)
+ (native-inputs
+ (list autoconf automake gettext-minimal libtool))
(inputs
(list bash-minimal util-linux))
(arguments
@@ -3309,6 +3312,10 @@ or kill them altogether.")
"/lib/udev/rules.d"))
#:phases
(modify-phases %standard-phases
+ (add-before 'bootstrap 'force-bootstrap
+ (lambda _
+ ;; Force a bootstrap to make the patch changes effective.
+ (delete-file "configure")))
(add-before 'build 'set-file-names
(lambda* (#:key inputs #:allow-other-keys)
;; libfuse calls out to mount(8) and umount(8). Make sure