summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2022-07-20 11:25:31 -0400
committer宋文武 <iyzsong@member.fsf.org>2022-08-04 15:10:02 +0800
commitd921cf8d279daa67406445aed5828564f059600c (patch)
treeba781bd6bcea42bcb240dd2a2d76dc04c4702b59 /gnu/packages/linux.scm
parentb8b8df9122510671f01940d35cf06e673f3afa4f (diff)
gnu: sshfs: Update to 3.7.3.
* gnu/packages/linux.scm (sshfs): Update to 3.7.3. [build-system]: Replace gnu-build-system with meson-build-system. [native-inputs]: Add dependencies to generate man page. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a94e5c9bc9..a9594905d9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3472,20 +3472,25 @@ UnionFS-FUSE additionally supports copy-on-write.")
(define-public sshfs
(package
(name "sshfs")
- (version "2.10")
+ (version "3.7.3")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/libfuse/sshfs/releases/"
"download/sshfs-" version "/sshfs-" version
- ".tar.gz"))
+ ".tar.xz"))
(sha256
(base32
- "00fir2iykdx11g8nv5gijg0zjrp2g3ldypnv0yi6lq3h5pg5v13h"))))
- (build-system gnu-build-system)
+ "169fkilv060afgp9h7hvsbkg02bd1y77kmx06x0s7q1cvmxww62j"))))
+ (build-system meson-build-system)
+ (arguments
+ ;; XXX: tests are skipped: FUSE kernel module does not seem to be loaded
+ '(#:tests? #f))
(inputs
- (list fuse glib))
+ (list fuse-3 glib))
(native-inputs
- (list pkg-config))
+ (list pkg-config
+ ;; man page
+ python-docutils))
(home-page "https://github.com/libfuse/sshfs")
(synopsis "Mount remote file systems over SSH")
(description