summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2024-04-08 20:13:38 +0200
committerLeo Famulari <leo@famulari.name>2024-04-30 17:50:21 -0400
commit238a74c7dfd1469af064b445abcee38fd7408d5b (patch)
treee9caed068d25e7ed867987db2b359e9fc699f3e6 /gnu/packages/linux.scm
parent147f1f2e0d3fe3b267f3e0f7c1d859bcb779c850 (diff)
gnu: Remove linux-libre 6.7.
* gnu/packages/linux.scm (linux-libre-6.7-version, linux-libre-6.7-gnu-revision, deblob-scripts-6.7, linux-libre-6.7-pristine-source, linux-libre-6.7-source, linux-libre-headers-6.7, linux-libre-6.7): Remove variables. * gnu/packages/aux-files/linux-libre/6.7-arm.conf, gnu/packages/aux-files/linux-libre/6.7-arm64.conf, gnu/packages/aux-files/linux-libre/6.7-i686.conf, gnu/packages/aux-files/linux-libre/6.7-x86_64.conf: Delete files. * Makefile.am (AUX_FILES): Remove aforementioned .conf files. Change-Id: Ic69a65e1fbfa59d893e85d26950f33195ea9fbe1 Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm42
1 files changed, 3 insertions, 39 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0b918cbc9c..b947997885 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -500,7 +500,9 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
"linux-" version ".tar.xz"))
(sha256 hash)))
-;; The current "mainline" kernel.
+
+;; The current "stable" kernels. That is, the most recently released major
+;; versions that are still supported upstream.
(define-public linux-libre-6.8-version "6.8.8")
(define-public linux-libre-6.8-gnu-revision "gnu")
@@ -517,26 +519,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-6.8)))
-
-
-;; The current "stable" kernels. That is, the most recently released major
-;; versions that are still supported upstream.
-
-(define-public linux-libre-6.7-version "6.7.12")
-(define-public linux-libre-6.7-gnu-revision "gnu")
-(define deblob-scripts-6.7
- (linux-libre-deblob-scripts
- linux-libre-6.7-version
- linux-libre-6.7-gnu-revision
- (base32 "1ddngihfmwffgvxxv8xsppi76r6grvdxr6zzfzvgl9qw07a6c9fd")
- (base32 "16zh4cj1q7khl943ij4fzc815plbcdllns93chv6725gsm338hsl")))
-(define-public linux-libre-6.7-pristine-source
- (let ((version linux-libre-6.7-version)
- (hash (base32 "113rf3jqfpf3wcv637zbq5ww2hpaaf23y6dsmkds01l8jkipjabc")))
- (make-linux-libre-source version
- (%upstream-linux-source version hash)
- deblob-scripts-6.7)))
-
;; The "longterm" kernels — the older releases with long-term upstream support.
;; Here are the support timelines:
;; <https://www.kernel.org/category/releases.html>
@@ -664,11 +646,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(list %boot-logo-patch
%linux-libre-arm-export-__sync_icache_dcache-patch)))
-(define-public linux-libre-6.7-source
- (source-with-patches linux-libre-6.7-pristine-source
- (list %boot-logo-patch
- %linux-libre-arm-export-__sync_icache_dcache-patch)))
-
(define-public linux-libre-6.6-source
(source-with-patches linux-libre-6.6-pristine-source
(list %boot-logo-patch
@@ -789,11 +766,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
linux-libre-6.8-gnu-revision
linux-libre-6.8-source))
-(define-public linux-libre-headers-6.7
- (make-linux-libre-headers* linux-libre-6.7-version
- linux-libre-6.7-gnu-revision
- linux-libre-6.7-source))
-
(define-public linux-libre-headers-6.6
(make-linux-libre-headers* linux-libre-6.6-version
linux-libre-6.6-gnu-revision
@@ -1133,14 +1105,6 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
;;; Generic kernel packages.
;;;
-(define-public linux-libre-6.7
- (make-linux-libre* linux-libre-6.7-version
- linux-libre-6.7-gnu-revision
- linux-libre-6.7-source
- '("x86_64-linux" "i686-linux" "armhf-linux"
- "aarch64-linux" "powerpc64le-linux" "riscv64-linux")
- #:configuration-file kernel-config))
-
(define-public linux-libre-6.8
(make-linux-libre* linux-libre-6.8-version
linux-libre-6.8-gnu-revision