summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-06-30 21:12:23 -0400
committerLeo Famulari <leo@famulari.name>2022-07-01 11:32:28 -0400
commitce9fbdd413d758ec4ab855d666825ad4e7bc5638 (patch)
tree201cb249f93258031a9d3df8da65eaea1ebf37e8 /gnu/packages/linux.scm
parenta90158a9e4d73b886a960bd1fe0551a41d4d8004 (diff)
gnu: linux-libre 5.15: Update to 5.15.51.
* gnu/packages/linux.scm (linux-libre-5.15-version): Update to 5.15.51. (linux-libre-5.15-pristine-source): Update hash.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index aaf3712ef0..c5e9b3b310 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -364,13 +364,14 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(let ((version linux-libre-5.18-version)
(hash (base32 "0dhaj1zcsr5sfg62byzvvkhm9j419px6v9v04ngcy0d0vc2yn8q8")))
(make-linux-libre-source version
+
(%upstream-linux-source version hash)
deblob-scripts-5.18)))
;; The "longterm" kernels — the older releases with long-term upstream support.
;; Here are the support timelines:
;; <https://www.kernel.org/category/releases.html>
-(define-public linux-libre-5.15-version "5.15.50")
+(define-public linux-libre-5.15-version "5.15.51")
(define-public linux-libre-5.15-gnu-revision "gnu")
(define deblob-scripts-5.15
(linux-libre-deblob-scripts
@@ -380,7 +381,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(base32 "129qlhwdv2mfb85gbvq03kkbdfp73b444rryr4rrbvi0jmq4cp24")))
(define-public linux-libre-5.15-pristine-source
(let ((version linux-libre-5.15-version)
- (hash (base32 "03yp3gz45059gkzqbijbg503rxx4wihjg4c3ikz10f526xym0kam")))
+ (hash (base32 "1229m4r4n61n5l8anp2pcqdhajkwmavhr1z00n8gvx3yn9w4ifhz")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.15)))