summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-22 13:20:46 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-22 15:58:32 +0100
commit6aa8f213c42d30e16da0564b5a9afde22de03d60 (patch)
treea9335ae8072ee51f48fca33294335ef111ea4154 /gnu/packages/linux.scm
parentb7c392a697992e3c420e1eee4e222736618ce601 (diff)
gnu: acpi-call-linux-module: Update to 1.2.1.
This decrements VERSION to match (pre-fork) upstream's. One doesn't ‘guix install’ kernel modules so I don't expect problems in practice. * gnu/packages/linux.scm (acpi-call-linux-module): Update to 1.2.1. [source]: Update renamed upstream.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm66
1 files changed, 32 insertions, 34 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3e07ff5f97..159fa2a206 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1042,39 +1042,37 @@ It has been modified to remove all non-free binary blobs.")
;;;
(define-public acpi-call-linux-module
- (let ((commit "70b9c80bd700e6a4d10797eaac9fd34b7e8cbd4a")
- (revision "0"))
- (package
- (name "acpi-call-linux-module")
- (version (git-version "3.17" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/teleshoes/acpi_call")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "09c1vw6vcrkqxbwhpgfgpj4d1grzn4qq6ka8pwwzm7cvm405xj7x"))))
- (build-system linux-module-build-system)
- (arguments
- `(#:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-documentation
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (string-append out "/share/doc/" ,name "-" ,version)))
- (for-each (lambda (file)
- (let ((target (string-append doc "/" file)))
- (mkdir-p (dirname target))
- (copy-recursively file target)))
- (list "README.md" "examples"))
- #t))))))
- (home-page "https://github.com/teleshoes/acpi_call")
- (synopsis "Linux kernel module to perform ACPI method calls")
- (description
- "This simple Linux kernel module allows calls from user space to any
+ (package
+ (name "acpi-call-linux-module")
+ (version "1.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nix-community/acpi_call")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0mr4rjbv6fj4phf038addrgv32940bphghw2v9n1z4awvw7wzkbg"))))
+ (build-system linux-module-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-documentation
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" ,name "-" ,version)))
+ (for-each (lambda (file)
+ (let ((target (string-append doc "/" file)))
+ (mkdir-p (dirname target))
+ (copy-recursively file target)))
+ (list "README.md" "examples"))
+ #t))))))
+ (home-page "https://github.com/teleshoes/acpi_call")
+ (synopsis "Linux kernel module to perform ACPI method calls")
+ (description
+ "This simple Linux kernel module allows calls from user space to any
@acronym{ACPI, Advanced Configuration and Power Interface} method provided by
your computer's firmware, by writing to @file{/proc/acpi/call}. You can pass
any number of parameters of types @code{ACPI_INTEGER}, @code{ACPI_STRING},
@@ -1082,7 +1080,7 @@ and @code{ACPI_BUFFER}.
It grants direct and undocumented access to your hardware that may cause damage
and should be used with caution, especially on untested models.")
- (license license:gpl3+)))) ; see README.md (no licence headers)
+ (license license:gpl3+))) ; see README.md (no licence headers)
(define-public rtl8812au-aircrack-ng-linux-module
(let ((commit "df2b8dfd8cb7d9f6cfeb55abaeab8a5372011fc9")