summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-01-10 19:31:58 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-01-10 19:35:34 +0100
commitf40ae739bce67a6da17450cf5ce9cce39c7c4ce3 (patch)
tree2ec3ed633c3357930a2ae7a95ad94d5e1b9d0e31 /gnu/packages/linux.scm
parent2dba37e27a75c4a8ffac324d419c020f1b900d66 (diff)
gnu: linux: Don't timeout on blob scan.
On berlin, linux-libre blob scanning timeouts after 600 seconds, increase max-silent-time to 3600 seconds. * gnu/packages/linux.scm (make-linux-libre*): Set max-silent-time property to 3600.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 46b86186e9..77277e2067 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -850,7 +850,8 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(description
"GNU Linux-Libre is a free (as in freedom) variant of the Linux kernel.
It has been modified to remove all non-free binary blobs.")
- (license license:gpl2)))
+ (license license:gpl2)
+ (properties '((max-silent-time . 3600))))) ;don't timeout on blob scan.
;;;