summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-10-30 11:26:35 -0400
committerLeo Famulari <leo@famulari.name>2022-11-02 01:01:51 -0400
commit2fde8cf3995c4cf7b9bc5e4fe0864172a896bbfb (patch)
tree21ac30d8c04b5d5eae7b0a03f496ca4301aa4e7e /gnu/packages/linux.scm
parentc6d94920090da1d4a5533bfa6c4f86baec1e078c (diff)
gnu: linux-libre: Add linux-libre 6.0.6.
* gnu/packages/linux.scm (linux-libre-6.0-version, linux-libre-6.0-pristine-source, linux-libre-6.0-source, linux-libre-headers-6.0, linux-libre-6.0): New variables. * gnu/packages/aux-files/linux-libre/6.0-arm.conf, gnu/packages/aux-files/linux-libre/6.0-arm64.conf, gnu/packages/aux-files/linux-libre/6.0-i686.conf, gnu/packages/aux-files/linux-libre/6.0-x86_64.conf: New files. * Makefile.am (AUX_FILES): Add them.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm35
1 files changed, 34 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1a8abf70bc..1690957954 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -355,6 +355,22 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; The current "stable" kernels. That is, the most recently released major
;; versions that are still supported upstream.
+(define-public linux-libre-6.0-version "6.0.6")
+(define-public linux-libre-6.0-gnu-revision "gnu")
+(define deblob-scripts-6.0
+ (linux-libre-deblob-scripts
+ linux-libre-6.0-version
+ linux-libre-6.0-gnu-revision
+ (base32 "0iwbjrgiwch5v1xpnm9wk9zqw2v6lxja0k8yj2x0amxc9ma68176")
+ (base32 "1x8nqdf338gqsn8d825xgvx44nawdy28zkg3cdmfxn09g749g6pz")))
+(define-public linux-libre-6.0-pristine-source
+ (let ((version linux-libre-6.0-version)
+ (hash (base32 "1akzfkwjbxki6r41gcnp5fml389i8ng9bid9c4ysg6w65nphajw6")))
+ (make-linux-libre-source version
+ (%upstream-linux-source version hash)
+ deblob-scripts-6.0)))
+
+
(define-public linux-libre-5.19-version "5.19.17")
(define-public linux-libre-5.19-gnu-revision "gnu")
(define deblob-scripts-5.19
@@ -370,7 +386,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-5.19)))
-
;; The "longterm" kernels — the older releases with long-term upstream support.
;; Here are the support timelines:
;; <https://www.kernel.org/category/releases.html>
@@ -492,6 +507,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(patches (append (origin-patches source)
patches))))
+(define-public linux-libre-6.0-source
+ (source-with-patches linux-libre-6.0-pristine-source
+ (list %boot-logo-patch
+ %linux-libre-arm-export-__sync_icache_dcache-patch)))
+
(define-public linux-libre-5.19-source
(source-with-patches linux-libre-5.19-pristine-source
(list %boot-logo-patch
@@ -606,6 +626,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(description "Headers of the Linux-Libre kernel.")
(license license:gpl2)))
+(define-public linux-libre-headers-6.0
+ (make-linux-libre-headers* linux-libre-6.0-version
+ linux-libre-6.0-gnu-revision
+ linux-libre-6.0-source))
+
(define-public linux-libre-headers-5.19
(make-linux-libre-headers* linux-libre-5.19-version
linux-libre-5.19-gnu-revision
@@ -935,6 +960,14 @@ It has been modified to remove all non-free binary blobs.")
;;; Generic kernel packages.
;;;
+(define-public linux-libre-6.0
+ (make-linux-libre* linux-libre-6.0-version
+ linux-libre-6.0-gnu-revision
+ linux-libre-6.0-source
+ '("x86_64-linux" "i686-linux" "armhf-linux"
+ "aarch64-linux" "powerpc64le-linux" "riscv64-linux")
+ #:configuration-file kernel-config))
+
(define-public linux-libre-5.19
(make-linux-libre* linux-libre-5.19-version
linux-libre-5.19-gnu-revision