summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-11-04 16:02:38 -0400
committerLeo Famulari <leo@famulari.name>2022-11-08 12:54:32 -0500
commitc52cdd18d6f8dddd69dfb1f8b5214a0db6ebb562 (patch)
tree310f7a4d1a8e6bee52432f9cb35a6952cd3fd08d /gnu/packages/linux.scm
parent96ae718c516a289124a0b91ceeef78b20d187825 (diff)
gnu: Remove linux-libre 5.19.
* gnu/packages/linux.scm (linux-libre-5.19-version, linux-libre-5.19-gnu-revision, deblob-scripts-5.19, linux-libre-5.19-pristine-source, linux-libre-5.19-source, linux-libre-headers-5.19, linux-libre-5.19): Remove variables. * gnu/packages/aux-files/linux-libre/5.19-arm.conf, gnu/packages/aux-files/linux-libre/5.19-arm64.conf, gnu/packages/aux-files/linux-libre/5.19-i686.conf, gnu/packages/aux-files/linux-libre/5.19-x86_64.conf: Delete files. * Makefile.am (AUX_FILES): Remove them.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm34
1 files changed, 0 insertions, 34 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d00b683dd9..535780cd2e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -370,22 +370,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-6.0)))
-
-(define-public linux-libre-5.19-version "5.19.17")
-(define-public linux-libre-5.19-gnu-revision "gnu")
-(define deblob-scripts-5.19
- (linux-libre-deblob-scripts
- linux-libre-5.19-version
- linux-libre-5.19-gnu-revision
- (base32 "1lk90psz33ldb8aiaws4iayhycl5bmywr6badvzffjpr87s5phxw")
- (base32 "092myqjixvy1k3ylcj0hfc4whfxapjvxsxm4gk30a3jv5dnh7mly")))
-(define-public linux-libre-5.19-pristine-source
- (let ((version linux-libre-5.19-version)
- (hash (base32 "12cly10lad12idjwlgh2g0pp4hhj57h2qi4fy6jg1lbsm62b6fy9")))
- (make-linux-libre-source version
- (%upstream-linux-source version hash)
- deblob-scripts-5.19)))
-
;; The "longterm" kernels — the older releases with long-term upstream support.
;; Here are the support timelines:
;; <https://www.kernel.org/category/releases.html>
@@ -512,11 +496,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(list %boot-logo-patch
%linux-libre-arm-export-__sync_icache_dcache-patch)))
-(define-public linux-libre-5.19-source
- (source-with-patches linux-libre-5.19-pristine-source
- (list %boot-logo-patch
- %linux-libre-arm-export-__sync_icache_dcache-patch)))
-
(define-public linux-libre-5.15-source
(source-with-patches linux-libre-5.15-pristine-source
(list %boot-logo-patch
@@ -631,11 +610,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
linux-libre-6.0-gnu-revision
linux-libre-6.0-source))
-(define-public linux-libre-headers-5.19
- (make-linux-libre-headers* linux-libre-5.19-version
- linux-libre-5.19-gnu-revision
- linux-libre-5.19-source))
-
(define-public linux-libre-headers-5.15
(make-linux-libre-headers* linux-libre-5.15-version
linux-libre-5.15-gnu-revision
@@ -968,14 +942,6 @@ It has been modified to remove all non-free binary blobs.")
"aarch64-linux" "powerpc64le-linux" "riscv64-linux")
#:configuration-file kernel-config))
-(define-public linux-libre-5.19
- (make-linux-libre* linux-libre-5.19-version
- linux-libre-5.19-gnu-revision
- linux-libre-5.19-source
- '("x86_64-linux" "i686-linux" "armhf-linux"
- "aarch64-linux" "powerpc64le-linux" "riscv64-linux")
- #:configuration-file kernel-config))
-
(define-public linux-libre-version linux-libre-6.0-version)
(define-public linux-libre-gnu-revision linux-libre-6.0-gnu-revision)
(define-public linux-libre-pristine-source linux-libre-6.0-pristine-source)