summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-05-31 00:27:03 -0400
committerMark H Weaver <mhw@netris.org>2018-05-31 00:27:03 -0400
commit0d6f84aab1c2f4cd8ce1b68215a7a77426dc6cd5 (patch)
tree714784ba10d8b4f9f33393d285d148024ba5dea8 /gnu/packages/linux.scm
parent03d90319622a9fd9df1cf69cf123ed550e870276 (diff)
parent88a3465e4a467be92729fc37d8bda0155bbf5c52 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm61
1 files changed, 53 insertions, 8 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0581dbd5bc..4100db5d8a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -395,8 +395,8 @@ It has been modified to remove all non-free binary blobs.")
;; supports qemu "virt" machine and possibly a large number of ARM boards.
;; See : https://wiki.debian.org/DebianKernel/ARMMP.
-(define %linux-libre-version "4.16.12")
-(define %linux-libre-hash "1zjq16z5cdcpa4acqdilavjjv2xbqnh3fmn400n9hd5pzyll817m")
+(define %linux-libre-version "4.16.13")
+(define %linux-libre-hash "1frpqxv5ykf87hrmh62b8nxxcpv64a5w7lxw51z4vs82799inmng")
(define-public linux-libre
(make-linux-libre %linux-libre-version
@@ -404,25 +404,52 @@ It has been modified to remove all non-free binary blobs.")
%linux-compatible-systems
#:configuration-file kernel-config))
-(define %linux-libre-4.14-version "4.14.44")
-(define %linux-libre-4.14-hash "0w89y22by17yqk89l1mmhlvz0i4dkp1mjc347nq3zy1llbwiwvnf")
+(define %linux-libre-4.14-version "4.14.46")
+(define %linux-libre-4.14-hash "17imkhqk3m3djdj0m5h4lqs9cfdh9zq1cz83q8ldyald56rbn622")
(define-public linux-libre-4.14
(make-linux-libre %linux-libre-4.14-version
%linux-libre-4.14-hash
'("x86_64-linux" "i686-linux" "armhf-linux")
+ #:patches
+ (list %boot-logo-patch
+ (origin
+ ;; The sole fix in the 4.14.47 release.
+ (method url-fetch)
+ (uri "https://git.kernel.org/pub/scm/linux/kernel/\
+git/stable/linux-stable.git/patch/?id=3e496be2038a100fc53627238fe120dc4c948719")
+ (sha256
+ (base32 "1hk1qd6v97zf8an3zww60zhsah1wwax22b3bpdzmfjhhbndyram9"))))
#:configuration-file kernel-config))
(define-public linux-libre-4.9
- (make-linux-libre "4.9.103"
- "00g58y92pmb6xf9lhjrab2jrjv3naw3857pf9s43dvh6fwlbccbf"
+ (make-linux-libre "4.9.104"
+ "0b6y24vfsjhiv7qq7xqx7h9krc81c49dqh0189nm1lhfwciyir57"
%intel-compatible-systems
+ #:patches
+ (list %boot-logo-patch
+ (origin
+ ;; The sole fix in the 4.9.105 release.
+ (method url-fetch)
+ (uri "https://git.kernel.org/pub/scm/linux/kernel/\
+git/stable/linux-stable.git/patch/?id=98d69fb3b175855cdd4c37d41a4b477a0860b1a0")
+ (sha256
+ (base32 "1r52fr0w94fgw7nfxrysjk0mljlnqwqsnl0cp84c1sly466i79dv"))))
#:configuration-file kernel-config))
(define-public linux-libre-4.4
- (make-linux-libre "4.4.133"
- "05qc9smcvxd68d46l5gjhvihhnidkiymqh4fv4nyagzv555q7na7"
+ (make-linux-libre "4.4.134"
+ "137mklzyv56yhc48l5h5i0h01gm1q40x2a8nk51lwhbjv592xr8x"
%intel-compatible-systems
+ #:patches
+ (list %boot-logo-patch
+ (origin
+ ;; The sole fix in the 4.4.135 release.
+ (method url-fetch)
+ (uri "https://git.kernel.org/pub/scm/linux/kernel/\
+git/stable/linux-stable.git/patch/?id=393e9b3c30d571c2f655aa24b0dee5be9ce249b5")
+ (sha256
+ (base32 "02wk036v525qwqs42ndqqj4mv8xfkpavibfg5ns6hkg2wc5a1jid"))))
#:configuration-file kernel-config))
(define-public linux-libre-4.1
@@ -443,6 +470,15 @@ It has been modified to remove all non-free binary blobs.")
%linux-libre-4.14-hash
'("armhf-linux")
#:defconfig "multi_v7_defconfig"
+ #:patches
+ (list %boot-logo-patch
+ (origin
+ ;; The sole fix in the 4.14.47 release.
+ (method url-fetch)
+ (uri "https://git.kernel.org/pub/scm/linux/kernel/\
+git/stable/linux-stable.git/patch/?id=3e496be2038a100fc53627238fe120dc4c948719")
+ (sha256
+ (base32 "1hk1qd6v97zf8an3zww60zhsah1wwax22b3bpdzmfjhhbndyram9"))))
#:extra-version "arm-generic"))
(define-public linux-libre-arm-omap2plus
@@ -457,6 +493,15 @@ It has been modified to remove all non-free binary blobs.")
%linux-libre-4.14-hash
'("armhf-linux")
#:defconfig "omap2plus_defconfig"
+ #:patches
+ (list %boot-logo-patch
+ (origin
+ ;; The sole fix in the 4.14.47 release.
+ (method url-fetch)
+ (uri "https://git.kernel.org/pub/scm/linux/kernel/\
+git/stable/linux-stable.git/patch/?id=3e496be2038a100fc53627238fe120dc4c948719")
+ (sha256
+ (base32 "1hk1qd6v97zf8an3zww60zhsah1wwax22b3bpdzmfjhhbndyram9"))))
#:extra-version "arm-omap2plus"))