summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-05-14 11:27:12 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-05-16 16:16:21 +0200
commit81b98756a3164e6b0024b64ea5c90bbb615de12a (patch)
treebcc23f811bcd63b31a52a5f30a7444dbb291beda /gnu/packages/linux.scm
parent002528bca512c2f45a7880e09be7c655bba7d2b0 (diff)
gnu: Add SBC.
* gnu/packages/linux.scm (sbc): New variable.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d489e7292b..97514c7b8e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2016 Raymond Nicholson <rain1@openmailbox.org>
;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2386,6 +2387,29 @@ system calls, important for the performance of databases and other advanced
applications.")
(license license:lgpl2.1+)))
+(define-public sbc
+ (package
+ (name "sbc")
+ (version "1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.kernel.org/pub/linux/bluetooth/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "02ckd2z51z0h85qgv7x8vv8ybp5czm9if1z78411j53gaz7j4476"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libsndfile" ,libsndfile)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://www.kernel.org/pub/linux/bluetooth/")
+ (synopsis "Bluetooth subband audio codec")
+ (description
+ "The SBC is a digital audio encoder and decoder used to transfer data to
+Bluetooth audio output devices like headphones or loudspeakers.")
+ (license license:gpl2+)))
+
(define-public bluez
(package
(name "bluez")