summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-08 23:58:22 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-08 23:58:22 +0200
commit873325b0307a709be6f305472a5bfb9e07437aaa (patch)
treeb271f28b229f983841ca7b16c4d3cc52582c864e /gnu/packages/linux.scm
parent68ee10da03b09c2acead8891e4b51c718c24d574 (diff)
parent6a8299d267d111da4c80bbdfc83eb5cdfc072b4a (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm22
1 files changed, 8 insertions, 14 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 5c1f679a36..6c79f29837 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -402,8 +402,8 @@ It has been modified to remove all non-free binary blobs.")
;; supports qemu "virt" machine and possibly a large number of ARM boards.
;; See : https://wiki.debian.org/DebianKernel/ARMMP.
-(define %linux-libre-version "4.17.3")
-(define %linux-libre-hash "06mjbs3i0xq1h1cgr6xldr6a8rxsy30mf86wp3n2ff6l5v78iw2q")
+(define %linux-libre-version "4.17.4")
+(define %linux-libre-hash "1qdywncwwaxghjidihyzvdjq7pffzlswlspjyy420ny967n818jd")
(define-public linux-libre
(make-linux-libre %linux-libre-version
@@ -411,8 +411,8 @@ It has been modified to remove all non-free binary blobs.")
%linux-compatible-systems
#:configuration-file kernel-config))
-(define %linux-libre-4.14-version "4.14.52")
-(define %linux-libre-4.14-hash "0lx916iw33n32h1fca59r7mh6l2smyml6igvzhimcah62hqx4rk8")
+(define %linux-libre-4.14-version "4.14.53")
+(define %linux-libre-4.14-hash "1bl20q85vnhbkmjj6gvqhgp379hk26rrivwmc5g5wqz46xyavk2a")
(define-public linux-libre-4.14
(make-linux-libre %linux-libre-4.14-version
@@ -421,20 +421,14 @@ It has been modified to remove all non-free binary blobs.")
#:configuration-file kernel-config))
(define-public linux-libre-4.9
- (make-linux-libre "4.9.110"
- "0nzfna9w9a45y521d3dcxkdv66gn38n4pq814rdqazk74qb5macn"
+ (make-linux-libre "4.9.111"
+ "0ld57627k6mjp14x5bvndakj6lc4l31zp2yq74h7ski2g3k7ppk2"
%intel-compatible-systems
#:configuration-file kernel-config))
(define-public linux-libre-4.4
- (make-linux-libre "4.4.138"
- "1030ra5gn24qmx8lsnhr6kfnfm60avzs23r81dl7mvzr5dci8vsl"
- %intel-compatible-systems
- #:configuration-file kernel-config))
-
-(define-public linux-libre-4.1
- (make-linux-libre "4.1.52"
- "0a2flzf79kz9c1y9zpxdclsfivp38d2sgnwifg4gvyqixdy63sk9"
+ (make-linux-libre "4.4.139"
+ "0x58ykgx7vbv23q763ydifi548mz39nal7wbvrrl4i9ndk7pzfzz"
%intel-compatible-systems
#:configuration-file kernel-config))