summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-05-23 14:42:36 +0200
committerLudovic Courtès <ludo@gnu.org>2018-05-24 23:38:47 +0200
commit914205214cd906044411e6438be69c700e355b0d (patch)
treec56a6ba730477e314c910d086f2b8beb177090c0 /gnu/packages/linux.scm
parent109f022e9d8937eeaaada5fd0350b77b888b3949 (diff)
gnu: ntfs-3g: Link 'mount.ntfs' to 'mount.ntfs-3g'.
* gnu/packages/linux.scm (ntfs-3g)[arguments]: Add #:phases. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7ec62853e9..70e612995e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3432,7 +3432,19 @@ from userspace.")
"--with-fuse=external" ;use our own FUSE
"--enable-mount-helper"
"--enable-posix-acls"
- "--enable-xattr-mappings")))
+ "--enable-xattr-mappings")
+ #:phases
+ (modify-phases %standard-phases
+ ;; If users install ntfs-3g, they probably want to make it the
+ ;; default driver as well, so we opt for sensible defaults and link
+ ;; mount.ntfs to mount.ntfs-3g. (libmount tries to run mount.ntfs to
+ ;; mount NTFS filesystems.)
+ (add-after 'install 'install-link
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (sbin (string-append out "/sbin")))
+ (symlink "mount.ntfs-3g"
+ (string-append sbin "/mount.ntfs"))))))))
(home-page "https://www.tuxera.com/community/open-source-ntfs-3g/")
(synopsis "Read-write access to NTFS file systems")
(description