summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2020-12-23 22:43:10 -0500
committerEfraim Flashner <efraim@flashner.co.il>2020-12-26 20:02:30 +0200
commit29412200891b29aad2e8d64bcb351cc492407ff6 (patch)
tree4104cd86a6316d3bf727b45aa46135afb6a69561 /gnu/packages/linux.scm
parent4969b51d175497bfcc354c91803e9d70542b7113 (diff)
gnu: Add Linux-Libre-LTS.
Enables the choice of using current LTS version of linux-libre in Guix System. * gnu/packages/linux.scm (linux-libre-lts-version): New variable. * gnu/packages/linux.scm (linux-libre-lts-pristine-source): New variable. * gnu/packages/linux.scm (linux-libre-lts-source): New variable. * gnu/packages/linux.scm (linux-libre-lts): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 92bf1686f7..45a105ba11 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -931,6 +931,14 @@ It has been modified to remove all non-free binary blobs.")
("CONFIG_DEVPTS_MULTIPLE_INSTANCES" . #t))
%default-extra-linux-options)))
+;; Linux-Libre-LTS means the *current* long-term support version of Linux-Libre.
+;; Reference: https://jxself.org/linux-libre/
+
+(define-public linux-libre-lts-version linux-libre-5.10-version)
+(define-public linux-libre-lts-pristine-source linux-libre-5.10-pristine-source)
+(define-public linux-libre-lts-source linux-libre-5.10-source)
+(define-public linux-libre-lts linux-libre-5.10)
+
;;;
;;; Specialized kernel variants.