summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2019-05-07 23:41:00 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2019-05-07 23:41:00 +0200
commit5d51a9771d459d89dedfcd255b280a94050ae716 (patch)
treedadcec3c2802d7343097be7e5414eba4af090623 /gnu/packages/linux.scm
parent5b3d3cf71c1947bb43237b28d231d249f9dfbe49 (diff)
gnu: tlp: Update to 1.2.2.
* gnu/packages/linux.scm (tlp): Update to 1.2.2.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 64a3f18d25..975033aab2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4401,7 +4401,7 @@ interface in sysfs, which can be accomplished with the included udev rules.")
(define-public tlp
(package
(name "tlp")
- (version "1.2.1")
+ (version "1.2.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -4411,7 +4411,7 @@ interface in sysfs, which can be accomplished with the included udev rules.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0rcp9i0fisdm4h6799ffr696l1vl661fnwb2dij268nlwwmkr90g"))))
+ "059kxrpxx580mm6p0z2a421nxngszyh4yqqhbgvn04b6a7dbsa2w"))))
(inputs `(("bash" ,bash)
("dbus" ,dbus)
("ethtool" ,ethtool)
@@ -4445,6 +4445,8 @@ interface in sysfs, which can be accomplished with the included udev rules.")
(setenv "TLP_FLIB" (string-append out "/share/tlp/func.d"))
(setenv "TLP_ULIB" (string-append out "/lib/udev"))
(setenv "TLP_CONF" "/etc/tlp")
+ (setenv "TLP_ELOD"
+ (string-append out "/lib/elogind/system-sleep"))
(setenv "TLP_SHCPL"
(string-append out "/share/bash-completion/completions"))
(setenv "TLP_MAN" (string-append out "/share/man"))
@@ -4454,7 +4456,9 @@ interface in sysfs, which can be accomplished with the included udev rules.")
(add-before 'install 'fix-installation
(lambda _
;; Stop the Makefile from trying to create system directories.
- (substitute* "Makefile" (("\\[ -f \\$\\(_CONF\\) \\]") "#"))
+ (substitute* "Makefile"
+ (("\\[ -f \\$\\(_CONF\\) \\]") "#")
+ (("install -d -m 755 \\$\\(_VAR\\)") "#"))
#t))
(replace 'install
(lambda _