summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-01-06 02:14:42 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-01-06 02:53:54 +0100
commitacc87fae1307ee1f516783f024c7f362784daa39 (patch)
tree094788e6cbb46dedd24835915256da0fa2045743 /gnu/packages/linux.scm
parente1e42eacf82d62a49b3da634c0b8dd9b8e962a3d (diff)
gnu: Add turbostat.
* gnu/packages/linux.scm (turbostat): New public variable.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 71f21aa687..e69aeee28e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5364,6 +5364,45 @@ be installed and loaded separately. Only the original vendor firmware is
supported.")
(license license:gpl3+)))
+(define-public turbostat
+ (package
+ (name "turbostat")
+ ;; XXX turbostat reports a version like ‘20.09.30’ but using it here would
+ ;; make it harder to benefit from ‘free’ linux-libre package updates.
+ (version (package-version linux-libre))
+ (source (package-source linux-libre))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no test suite
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'enter-subdirectory
+ (lambda _
+ (chdir "tools/power/x86/turbostat")
+ #t))
+ (delete 'configure)))) ; no configure script
+ (inputs
+ `(("libcap" ,libcap)))
+ (supported-systems '("i686-linux" "x86_64-linux"))
+ (home-page (package-home-page linux-libre))
+ (synopsis "Report x86 processor frequency and idle statistics")
+ (description
+ "Turbostat reports x86 processor topology, frequency, idle power state
+statistics, temperature, and power consumption. Some information is unavailable
+on older processors.
+
+It can be used to identify machines that are inefficient in terms of power usage
+or idle time, report the rate of @acronym{SMI, system management interrupt}s
+occurring on the system, or verify the effects of power management tuning.
+
+@command{turbostat} reads hardware counters but doesn't write to them, so it
+won't interfere with the OS or other running processes---including multiple
+invocations of itself.")
+ (license license:gpl2)))
+
(define-public ntfs-3g
(package
(name "ntfs-3g")