summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-11-22 22:50:17 +0100
committerLudovic Courtès <ludo@gnu.org>2013-11-22 22:50:17 +0100
commit3cc20675231364bded3849287376cafba15f7a0b (patch)
treeb9beb2312cf735b03bd3cdc88323548018661880 /gnu/packages/linux.scm
parente3aaefe71bd26daf6fdbfd0634f68a90985e059b (diff)
gnu: Add libnl.
* gnu/packages/linux.scm (libnl): New variable.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e712c3cb9d..9a5127fbe4 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -755,3 +755,30 @@ Packets are forwarded based on Ethernet address, rather than IP address (like
a router). Since forwarding is done at Layer 2, all protocols can go
transparently through a bridge.")
(license gpl2+)))
+
+(define-public libnl
+ (package
+ (name "libnl")
+ (version "3.2.13")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.infradead.org/~tgr/libnl/files/libnl-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1ydw42lsd572qwrfgws97n76hyvjdpanwrxm03lysnhfxkna1ssd"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("flex" ,flex) ("bison" ,bison)))
+ (home-page "http://www.infradead.org/~tgr/libnl/")
+ (synopsis "NetLink protocol library suite")
+ (description
+ "The libnl suite is a collection of libraries providing APIs to netlink
+protocol based Linux kernel interfaces. Netlink is an IPC mechanism primarly
+between the kernel and user space processes. It was designed to be a more
+flexible successor to ioctl to provide mainly networking related kernel
+configuration and monitoring interfaces.")
+
+ ;; Most files are LGPLv2.1-only, but some are GPLv2-only (like
+ ;; 'nl-addr-add.c'), so the result is GPLv2-only.
+ (license gpl2)))