summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-06-09 23:52:39 +0200
committerLudovic Courtès <ludo@gnu.org>2013-06-09 23:54:55 +0200
commitba04571a833e70860bb67ad9af8255b51031ea22 (patch)
tree25be52cd777ac34e077545d0d02a29eeb79b27fa /gnu/packages/linux.scm
parentf88aeb6aa891f27c98af656498ca7857e610c6a7 (diff)
gnu: Add ALSA-lib; use it.
* gnu/packages/linux.scm (alsa-lib): New variable. * gnu/packages/oggvorbis.scm (ao): Add ALSA-lib as an input.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 734997ae57..0708b5cb81 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -429,3 +429,23 @@ slabtop, and skill.")
"strace is a system call tracer, i.e. a debugging tool which prints out a
trace of all the system calls made by a another process/program.")
(license bsd-3)))
+
+(define-public alsa-lib
+ (package
+ (name "alsa-lib")
+ (version "1.0.27.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "0fx057746dj7rjdi0jnvx2m9b0y1lgdkh1hks87d8w32xyihf3k9"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.alsa-project.org/")
+ (synopsis "The Advanced Linux Sound Architecture libraries")
+ (description
+ "The Advanced Linux Sound Architecture (ALSA) provides audio and
+MIDI functionality to the Linux-based operating system.")
+ (license lgpl2.1+)))