summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-04-01 17:37:07 -0400
committerMark H Weaver <mhw@netris.org>2015-04-01 17:38:47 -0400
commit5fd5e83da60626650c2c3136a4913b0401a446e9 (patch)
tree223e6a996d5e2173f1d37e34d4579837820622e4 /gnu/packages/linux.scm
parent1bb76f75232c755ff70a43bffa28745f9a32aceb (diff)
gnu: linux-libre: Update to 3.19.3.
The changes to linux-libre-*.conf are by Jason Self <j@jxself.org>. * gnu/packages/patches/linux-libre-libreboot-fix.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/linux.scm (linux-libre): Update to version 3.19.3. Add patch. * gnu/packages/linux-libre-i686.conf, gnu/packages/linux-libre-x86_64.conf: Update for 3.19.x. Co-Authored-By: Jason Self <j@jxself.org>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c48fefa7c2..38b940d071 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -198,7 +198,7 @@ for SYSTEM, or #f if there is no configuration for SYSTEM."
#f)))
(define-public linux-libre
- (let* ((version "3.18.10")
+ (let* ((version "3.19.3")
(build-phase
'(lambda* (#:key system inputs #:allow-other-keys #:rest args)
;; Apply the neat patch.
@@ -271,7 +271,9 @@ for SYSTEM, or #f if there is no configuration for SYSTEM."
(uri (linux-libre-urls version))
(sha256
(base32
- "0ckbi94b56klp59wsfcmlkbyrj7hj7kb7ys2jjsrqsk39dd77zg5"))))
+ "13nq0wzkjy7hrhnnvxlwzs1awlqd81vzriqddjn6s9ma3fzj44bn"))
+ (patches
+ (list (search-patch "linux-libre-libreboot-fix.patch")))))
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl)
("bc" ,bc)