summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-11-06 23:49:40 +0100
committerLudovic Courtès <ludo@gnu.org>2015-11-06 23:50:14 +0100
commit53ec8d48907b7d13c67ba76da9b85a8bbd97fc38 (patch)
tree2b3c64e8762042d61f7a18e124f4e88dee170688 /gnu/packages/linux.scm
parent235cba85286455901e591dc010a3e6c17d57b21c (diff)
gnu: Add GPM.
* gnu/packages/linux.scm (gpm): New variable.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index aa2fc0283b..a75ea2f05e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2410,3 +2410,46 @@ id=0B7CLI-REKbE3VTdaa0EzTkhYdU0")
"This package provides a FUSE-based file system that provides read and
write access to exFAT devices.")
(license gpl2+)))
+
+(define-public gpm
+ (package
+ (name "gpm")
+ (version "1.20.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.nico.schottelius.org/software/gpm/archives/gpm-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "13d426a8h403ckpc8zyf7s2p5rql0lqbg2bv0454x0pvgbfbf4gh"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'configure 'bootstrap
+ (lambda _
+ ;; The tarball was not generated with 'make dist' so we
+ ;; need to bootstrap things ourselves.
+ (and (zero? (system* "./autogen.sh"))
+ (begin
+ (patch-makefile-SHELL "Makefile.include.in")
+ #t)))))
+
+ ;; Make sure programs find libgpm.so.
+ #:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out")
+ "/lib"))))
+ (native-inputs
+ `(("texinfo" ,texinfo)
+ ("bison" ,bison)
+ ("flex" ,flex)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (home-page "http://www.nico.schottelius.org/software/gpm/")
+ (synopsis "Mouse support for the Linux console")
+ (description
+ "The GPM (general-purpose mouse) daemon is a mouse server for
+applications running on the Linux console. It allows users to select items
+and copy/paste text in the console and in xterm.")
+ (license gpl2+)))