summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-03-14 22:30:27 -0400
committerMark H Weaver <mhw@netris.org>2016-03-15 11:09:00 -0400
commit75b314a615e7f1a62483046eb1d569ed88fd8530 (patch)
tree4b8c7c1a66bb3f4be0b5f11aaaca64e6c46dc1bb /gnu/packages/linux.scm
parent4d343a141b4d30a04b239fd3070fb7c12ba8b4a0 (diff)
gnu: linux-libre: Update to 4.5, while preserving linux-libre-4.4.
* gnu/packages/linux-libre-x86_64.conf: Rename to ... * gnu/packages/linux-libre-4.4-x86_64.conf: ... this. * gnu/packages/linux-libre-i686.conf: Rename to ... * gnu/packages/linux-libre-4.4-i686.conf: ... this. * gnu/packages/linux-libre-4.5-i686.conf, gnu/packages/linux-libre-4.5-x86_64.conf: New files. * Makefile.am (KCONFIGS): Update accordingly. * gnu/packages/linux.scm (linux-libre): Update to 4.5. (linux-libre-4.4): New variable.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm27
1 files changed, 23 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 65f55fcf97..a2412d0ea0 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -220,7 +220,7 @@ for SYSTEM and optionally VARIANT, or #f if there is no such configuration."
(search-path %load-path file)))
(define-public linux-libre
- (let* ((version "4.4.5")
+ (let* ((version "4.5")
(build-phase
'(lambda* (#:key system inputs #:allow-other-keys #:rest args)
;; Apply the neat patch.
@@ -294,7 +294,7 @@ for SYSTEM and optionally VARIANT, or #f if there is no such configuration."
(uri (linux-libre-urls version))
(sha256
(base32
- "19yyw6yssyxr9k5y3whgz2p731mb1pnq3xajpv8g01m13cxs32dd"))))
+ "0km863vwy557flpygkr869yshpjs1v11ni78p8k9p9nm31ai6yn3"))))
(build-system gnu-build-system)
(supported-systems '("x86_64-linux" "i686-linux"))
(native-inputs `(("perl" ,perl)
@@ -303,8 +303,10 @@ for SYSTEM and optionally VARIANT, or #f if there is no such configuration."
("module-init-tools" ,module-init-tools)
("patch/freedo+gnu" ,%boot-logo-patch)
- ,@(let ((conf (kernel-config (or (%current-target-system)
- (%current-system)))))
+ ,@(let ((conf (kernel-config
+ (or (%current-target-system)
+ (%current-system))
+ #:variant (version-major+minor version))))
(if conf
`(("kconfig" ,conf))
'()))))
@@ -326,6 +328,23 @@ It has been modified to remove all non-free binary blobs.")
(license license:gpl2)
(home-page "http://www.gnu.org/software/linux-libre/"))))
+(define-public linux-libre-4.4
+ (package
+ (inherit linux-libre)
+ (version "4.4.5")
+ (source (origin
+ (method url-fetch)
+ (uri (linux-libre-urls version))
+ (sha256
+ (base32
+ "19yyw6yssyxr9k5y3whgz2p731mb1pnq3xajpv8g01m13cxs32dd"))))
+ (native-inputs
+ (let ((conf (kernel-config (or (%current-target-system)
+ (%current-system))
+ #:variant "4.4")))
+ `(,@(alist-delete "kconfig" (package-native-inputs linux-libre))
+ ("kconfig" ,conf))))))
+
(define-public linux-libre-4.1
(package
(inherit linux-libre)