summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-04-15 17:57:15 -0400
committerLeo Famulari <leo@famulari.name>2017-04-17 13:57:02 -0400
commit13223c8e5930cbcb8653e738f4bcda395c0cf70e (patch)
treee1e3d8f621cb4704995a5b57985cb009180aaf9b /gnu/packages/linux.scm
parentb754c6121bc95c5c5f7409c93c69cd0207888723 (diff)
gnu: iptables: Update to 1.6.1.
* gnu/packages/linux.scm (iptables): Update to 1.6.1. [source], [home-page]: Use HTTPS URLs. [inputs]: Add libmnl and libnftnl. [native-inputs]: Add bison, flex, and pkg-config.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7a744ede6f..7075e7c859 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1016,21 +1016,28 @@ external rate conversion.")
(define-public iptables
(package
(name "iptables")
- (version "1.4.21")
+ (version "1.6.1")
(source (origin
(method url-fetch)
(uri (string-append
- "http://www.netfilter.org/projects/iptables/files/iptables-"
+ "https://www.netfilter.org/projects/iptables/files/iptables-"
version ".tar.bz2"))
(sha256
(base32
- "1q6kg7sf0pgpq0qhab6sywl23cngxxfzc9zdzscsba8x09l4q02j"))))
+ "1x8c9y340x79djsq54bc1674ryv59jfphrk4f88i7qbvbnyxghhg"))))
(build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("flex" ,flex)
+ ("bison" ,bison)))
+ (inputs
+ `(("libmnl" ,libmnl)
+ ("libnftnl" ,libnftnl)))
(arguments
'(#:tests? #f ; no test suite
#:configure-flags ; add $libdir to the RUNPATH of executables
(list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))))
- (home-page "http://www.netfilter.org/projects/iptables/index.html")
+ (home-page "https://www.netfilter.org/projects/iptables/index.html")
(synopsis "Program to configure the Linux IP packet filtering rules")
(description
"iptables is the userspace command line program used to configure the